Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to set up a virtual machine which will act as a home security system. (If you've chatted with me in The Tavern, you may know why...) I purchased two USB webcams (Microsoft LifeCam HD-5000) and am trying to get them to work with Motion. However when I connected them to my Ubuntu 10.10 VM, no /dev/video devices were created. dmesg said:

jnet@sharon:~$ dmesg|tail
[  558.421978] uvcvideo: Failed to initialize the device (-5).
[  558.423487] usbcore: registered new interface driver uvcvideo
[  558.423492] USB Video Class driver (v0.1.0)
[  569.042808] usbcore: deregistering interface driver uvcvideo
[  570.840343] uvcvideo: Found UVC 1.00 device Microsoft® LifeCam HD-5000 (045e:076d)
[  585.801811] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[  595.775370] uvcvideo: Failed to query (129) UVC probe control : -110 (exp. 26).
[  595.775592] uvcvideo: Failed to initialize the device (-5).
[  595.777012] usbcore: registered new interface driver uvcvideo
[  595.777018] USB Video Class driver (v0.1.0)

There's a lot of results on Google for "uvcvideo: Failed to query (129) UVC probe control : -110 (exp. 26).". many people were saying to unload the uvcvideo module and reload it, because it loads before the usbaudio module. But no amount of unloading and reloading worked. A custom compile of the uvcvideo.ko module was suggested but the link to the source was dead.

Is there any way to make these webcams work under a *nix-like system? Please note it does not have to be Ubuntu, I was setting up a brand new VM for this purpose so I am open to any unix-like OS, be it Fedora, CentOS, a BSD flavor or even Open Solaris or similar.

share|improve this question
add comment

2 Answers

Here are two links, one is from Mint-linux saying it works in Mint. There are two videos on Youtube showing it being used with Mint and Ubuntu.

share|improve this answer
    
Awesome, I'll try Mint this weekend and see if that works! –  Josh Dec 15 '10 at 14:13
add comment
up vote 1 down vote accepted

Turns out the issue was VMware. No matter how hard I tried I couldn't make the camera work inside a virtual machine under VMware Server 2.0. Linux Mint was the only distro which even recognized it, and even then I kept getting errors that the camera could not be opened / IO errors.

Installing uvcvideo, cheese and motion directly on the host worked fine.


Three years later on a new host running VMware ESXi 5 I didn't have any of these problems, so it was a VMware Server 2 issue. (Now very, very outdated)

share|improve this answer
    
Have you tried running virtualbox as root, then dropping the camera in the virtual machine? –  Adam F Feb 17 at 21:31
1  
No @Adam, and I have since migrated to VMware ESXi which resolved the problem. I'll update my answer. –  Josh Feb 18 at 14:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.