Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm currently running Debian 6.0.5 on my white Macbook 2008 (4,1) and have recently noticed that when I download, move, or decompress a file, Gnome freezes up completely for at least 20 seconds. These freezes happen off and on until the file is done downloading. Oddly enough I can still use Compiz to switch between workspaces and move windows, but the windows aren't being redrawn. I did a lot of googling to see if I could find a solution to the problem, but not much turned up for my specific problem. I thought the problem might be related to me using a Seagate Momentus XT, as there seemed to be a lot of problems with that drive and linux in the past. It turns out that I'm using the updated firmware that was supposed to fix the linux problems the drive was having. If anyone has any ideas as to why this is happening and a potential fix to this problem, please let me know.

I get this error in the syslog:

Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330686] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330695] ata3.00: BMDMA stat 0x6
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330703] ata3.00: failed command: READ DMA EXT
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330717] ata3.00: cmd 25/00:00:80:64:b4/00:01:2c:00:00/e0 tag 0 dma 131072 in
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330721]          res 51/84:60:20:65:b4/84:00:2c:00:00/e0 Emask 0x30 (host bus error)
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330728] ata3.00: status: { DRDY ERR }
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330734] ata3.00: error: { ICRC ABRT }
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.330757] ata3: soft resetting link
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.510690] ata3.00: configured for UDMA/33
Sep 13 16:54:23 Thunder-Pussy kernel: [ 5713.510835] ata3: EH complete
share|improve this question
    
Does your kernel mention anything about the time of such an event? see /var/log/syslog. If it causes I/O errors or SCSI bus resets this may give a clue and more keywords to Google for. –  gertvdijk Sep 13 '12 at 20:43
    
I just checked the syslog file and I get the same error repeatedly. I can't add it to this comment because of size restrictions, I'll add it to the question. –  KylePlusPlus Sep 13 '12 at 21:07
    
Can you check the disk's SMART status to see if it's giving any failure? (use smartctl) –  Renan Sep 13 '12 at 23:27

1 Answer 1

Test the partitions with a livecd of some distro more updated. Mount the partition, write a lot of files and check the dmesg. The kernel of Debian Stable is old and if your problem is a kernel bug, probably is solved.

You also can try with other schedulers. Add "elevator=noop" or "elevator=deadline" to your grub. Sometimes, other schedulers can help with this type of issues.

If the two tests fail, your disk or controller is broken. Also you can check the healthy of your disk with the SMART tests.

share|improve this answer
1  
One more possibility: a loose cable. Rare, but can be fixed easily and cheaply. –  Gilles Sep 13 '12 at 23:45
    
Yes, or a broken connector. I forgot both. –  J.F. Sep 14 '12 at 0:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.