Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Yast on OpenSuse 12.1. When trying to install packages from the software repositories, I get an error that the repo cannot be accessed because the network is unreachable:

Download (curl) error for 'http://download.opensuse.org/update/12.1/repodata/repomd.xml': Error code: Connection failed Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable

I tried accessing this URL in the browser, and it works fine.

This question suggests that the system date may have reset itself, but that is not the case for me. While it's a duplicate question, the accepted answer there is incorrect for me.

share|improve this question

It seems that Yast is trying to use IPv6, which probably you don't have. According to documentation for openSUSE 12.2 you can turn IPv6 off in Network Settings or manually:

To enable or disable IPv6 manually, edit /etc/modprobe.d/50-ipv6.conf and restart the system.

It's working in browser probably because when IPv6 fails it falls back to IPv4. In Firefox there are two options for IPv6 in about:config:

share|improve this answer
Disabling the entire IPv6 stack just because of one buggy program is not a nice solution. – Adam Spiers Apr 26 at 14:38

I've had this happen a couple of times, due to network issues or time issues.

You mentioned you were able to get to the repo via web browser. Perhaps you were loading a cached version of the site.

Try the following, from a command line:

rcnetwork restart
zypper clean
zypper ref

You can go through YaST -> Network Devices -> Network Settings and disable IPv6 that way (it'll require a reset).

pbm's method works, but since you're already using YaST, I'm just showing how to do it through the GUI\TUI

Just for humor purposes, can you post the output of date?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.