Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a fresh Mint 13 Maya (MATE edition) with Compiz enabled. I also have a two-monitor set-up with the nVidia drivers with TwinView. I have set up 4 horizontal workspaces via CompizConfig Settings Manager.

Here is the behavior I try to eliminate: I open a window, say, browser, and put it to workspace number 2. When I switch to workspace 3 or 4, then back to workspace 2, the window is gone. It has jumped to workspace 1 somehow.

This annoys a lot. Could anyone help?

Here are some details:

  • If you stay on workspace 2 windows never jump
  • If you switch to workspace 1 and back to worspace 2 - windows do not jump. They seem to jump only if you switch to the right
  • I have 2 monitors, and this behavior occurs only with windows displayed on the left monitor
share|improve this question
    
What desktop environment/window manager? I've seen a feature in some WMs which allows you to grow and remove workspaces at will, maybe this is happening here. –  Bobby Sep 17 '12 at 11:58
add comment

2 Answers

Happens for me too - very annoying. I used to have 5 workspaces in a row under Ubuntu 10.04. However, I did find that putting 4 workspaces in 2 rows stops the windows from jumping around. It's harder to click on a workspace but that's my fix for now.

share|improve this answer
add comment

you should use CCSM (sudo apt-get install ccsm) to set "Desktop size" in the "General options" section

Set horizontal to, say, 4, vertical to 1, and (this is counterintuitive) number of desktops to 1

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.