Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I change the volume in mplayer it also changes for other applications. How can I configure mplayer to only change its own volume? Or is this a problem with the rest of the audio stack? I am using alsa with esd.

share|improve this question
up vote 8 down vote accepted

mplayer takes a -softvol flag that makes it use the software audio mixer instead of the sound card. If you want it on permanently, you can add the following to ~/.mplayer/config:

softvol=true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.