Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed and setup a guest Mageia 2 on VirtualBox which I plan to use as a development web server. My host is Windows 7 (64-bit) and I want to access the web sites from this host web browser.

I have set VirtualBox Network setting of Mageia guest OS to "Bridged Adapter" and I took the IP address of eth0 and entered that on my host web browser. But I am getting a timeout so I am thinking that the host and guest OSes are not communicating.

Prior to using Mageia, I had a Debian guest OS with the same setup and when I entered the IP address of the guest eth0 to my host web browser, the "It works!" page is shown. And I did not do any configurations.

I am thinking that it has something to do with the security features of my Mageia guest OS.

Just a note, the Mageia guest OS is a minimal install -- no GUI and just the bare packages are installed along with the LAMP packages. So everything is CLI.

I don't know where to start in getting access to my web server guest OS from host OS. Any tips?

share|improve this question
    
Can someone add the mageia tag? I still can't create tags so... –  Eric Sep 7 '12 at 11:24
add comment

1 Answer

up vote 2 down vote accepted

I got this running. By default, I guess Mageia doesn't allow access to the web server. There are 2 ways to do this.

  1. GUI way: Use the drakfirewall application. This opens a dialog where you can choose the services you want to enable in your system. Ticked the 'Web Server' check box and access to web server from external sources is granted.

  2. CLI way: (this is what I did because my VirtualBox instance did not have X). Go to /etc/shorewall/rules.drakx and append a line to the file with the ff.

    ACCEPT net fw tcp 80,443 -

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.