Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I got version 0.26 from libcanberra site, and running make gives:

make[2]: *** No rule to make target `README', needed by `all-am'.  Stop.
make[2]: Leaving directory `/home/wena/src/gnome/libcanberra-0.26/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/wena/src/gnome/libcanberra-0.26'
make: *** [all] Error 2

Output of ./configure:

prefix:                 /usr/local
sysconfdir:             ${prefix}/etc
localstatedir:          ${prefix}/var
Compiler:               gcc -std=gnu99
CFLAGS:                 -g -O2 -Wall -W -Wextra -pedantic -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wpacked -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wstrict-aliasing=2 -Wcast-align -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -fno-strict-aliasing
C++-Compiler:           g++
CXXFLAGS:               -g -O2
Builtin DSO:            yes
Enable PulseAudio:      yes
Builtin PulseAudio:     no
Enable ALSA:            yes
Builtin ALSA:           no
Enable OSS:             yes
Builtin OSS:            no
Enable GStreamer:       yes
Builtin GStreamer:      no
Enable Null Output:     yes
Builtin Null Output:    no
Enable tdb:             no
Enable lookup cache:    no
Enable GTK+:            yes
GTK Modules Directory:  ${exec_prefix}/lib/gtk-2.0/modules
Enable GTK3+:           yes
GTK3 Modules Directory: ${exec_prefix}/lib/gtk-3.0/modules


UPDATE: I'm no longer experiencing this problem and have no idea what fixed it.

share|improve this question
    
@Tshepang: Show us what make command you ran (make all-am?) and the full output from that command. And put a link to the source you downloaded. –  Gilles Dec 10 '10 at 18:32
    
@Gilles: make all IMHO juging on last lines. –  Maciej Piechotka Dec 11 '10 at 11:27
    
@Tshepang: maybe mark this one as answered so it doesn't keep popping up? –  Faheem Mitha Jun 16 '11 at 12:39
    
@FaheemMitha: even if the Answer didn't work? –  Tshepang Jun 20 '11 at 9:00
    
@Tshepang: Add your own answer, then accept it. "No longer experiencing" qualifies as an answer, I think. Another option would be to simply remove the question. –  Faheem Mitha Jun 20 '11 at 10:08

1 Answer 1

You're probably missing the GTK-Doc tools to generate documentation.

One way to find out these dependencies by looking at what distributions do to build the package. For example on Debian, in debian/control, the dependencies (except Debian-specific stuff) are

m4, libltdl-dev | libltdl7-dev (>= 2.2.6), libasound2-dev, libvorbis-dev, libgtk2.0-dev (>= 2.20), tdb-dev (> 1.1), gtk-doc-tools, libpulse-dev (>= 0.9.11), libgstreamer0.10-dev (>= 0.10.15)

share|improve this answer
    
The command for that is apt-get build-dep libcanberra. Anyways, I did run it and still got the same problem. BTW my problem got fixed later on by... who knows. I wish I could pinpoint what the trouble was :( –  Tshepang Dec 11 '10 at 8:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.