Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have the Firefly Media Server (mt-daap) set up on an Ubuntu 10.10 VM, and I Ubuntu 10.10 set up on my laptop. I am running Rhythmbox and using that to play the music files off the daap share. Unfortunetly, very few of the files play -- Rhythmbox just skips right over them and jumps to the next file. It has occasionally asked me to install a codec, and everytime it has asked I have authorized it to.

Almost all the files are m4a files, both the ones that play as well as the ones that don't/ The output of file for one that plays is:

ISO Media, MPEG v4 system, iTunes AAC-LC

The file command produces the same output for files which won't play. How can I troubleshoot this further / how can I make Rhythmbox play these other files?

share|improve this question
    
Just as a start, do you even have the required codecs/decoders installed? It took me a while to figure out that Ubuntu 10.10 couldn't play MP3's out-of-the-box... –  Blender Dec 10 '10 at 15:25
    
@Blender I'm not sure... how would I check? –  Josh Dec 10 '10 at 15:29
    
I posted the required package. Try that. –  Blender Dec 10 '10 at 15:30

2 Answers 2

Try installing ubuntu-restricted-extras. Ubuntu can't play MP3's and other closed-source encoders (AAC is one of them). You might even have to add a repository, but since I always enable all of those repos, this command worked for me:

sudo apt-get install ubuntu-restricted-extras

If you don't like the CLI too much, click here to open up Software Installer and do it via a GUI interface: apt:ubuntu-restricted-extras?section=universe?section=multiverse.

Good luck!


Also, if you're planning to play DVD's too, you might need to install the DVD decoders, as they are not included by default. To do that, run this (no GUI here):

sudo /usr/share/doc/libdvdread4/install-css.sh

I'm running out of ideas, but maybe these packages would work? I did some research, and these seemed to fix the problems you're having back in 2007, so the versions might have changed. If you're up to installing more random packages in a frantic attempt to play Apple's ridiculous format, here you go:

sudo apt-get install gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-bad faad libfaad2-0

Good luck, once more.

share|improve this answer
    
I <3 the CLI! -- running apt-get now, will post back shortly! –  Josh Dec 10 '10 at 15:30
    
Lol, CLI is always more pleasing that a progress bar. Also, look here for all of the restricted format stuff: help.ubuntu.com/community/RestrictedFormats. The Ubuntu help center is quite useful for quick troubleshooting. –  Blender Dec 10 '10 at 15:32
    
Sadly I installed that package, but Rhythmbox still skips 95% of the files in my library. :-( I'll check out the link you provided later. Thanks! –  Josh Dec 10 '10 at 15:40
    
Aww. I'll research some more, and see what I can dig up. Sorry! –  Blender Dec 10 '10 at 15:42
    
I'm really sorry Blender, this was an issue with mt-daapd, not with Rythmbox. I really appreciate all your hard work! –  Josh Dec 13 '10 at 20:21
up vote 1 down vote accepted

Turns out this was an issue with mt-daapd instead of with Rythmbox. I deleted the mt-daapd database cache and restarted the server, and after rebuilding the cache all the files now play. I'm sure installing all the software Blender mentioned helped!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.