Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Recently I saw this:

[root@NOTEBOOK /etc/yum.repos.d] yum update
Loaded plugins: fastestmirror, presto, security
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                        |  17 kB     00:00     
 * epel: mirror.pmf.kg.ac.rs
 * rpmforge: ftp.lug.ro
 * sl: ftp.scientificlinux.org
 * sl-security: ftp.scientificlinux.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wine.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine.x86_64 0:1.4.1-1.el6 will be an update
--> Processing Dependency: wine-openal(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-openal(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
---> Package wine-capi.i686 0:1.2.3-1.el6 will be updated
---> Package wine-capi.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-capi.i686 0:1.4.1-1.el6 will be an update
---> Package wine-capi.x86_64 0:1.4.1-1.el6 will be an update
---> Package wine-cms.i686 0:1.2.3-1.el6 will be updated
---> Package wine-cms.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-cms.i686 0:1.4.1-1.el6 will be an update
---> Package wine-cms.x86_64 0:1.4.1-1.el6 will be an update
---> Package wine-common.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-common.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-core.i686 0:1.2.3-1.el6 will be updated
---> Package wine-core.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-core.i686 0:1.4.1-1.el6 will be an update
--> Processing Dependency: libgstreamer-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
--> Processing Dependency: libgstbase-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
--> Processing Dependency: libgstapp-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
---> Package wine-core.x86_64 0:1.4.1-1.el6 will be an update
---> Package wine-courier-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-courier-fonts.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-desktop.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-desktop.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-fonts.noarch 0:1.4.1-1.el6 will be an update
--> Processing Dependency: wine-tahoma-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-ms-sans-serif-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
---> Package wine-ldap.i686 0:1.2.3-1.el6 will be updated
---> Package wine-ldap.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-ldap.i686 0:1.4.1-1.el6 will be an update
---> Package wine-ldap.x86_64 0:1.4.1-1.el6 will be an update
---> Package wine-marlett-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-marlett-fonts.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-pulseaudio.i686 0:1.2.3-1.el6 will be updated
---> Package wine-pulseaudio.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-pulseaudio.i686 0:1.4.1-1.el6 will be an update
--> Processing Dependency: wine-alsa(x86-32) = 1.4.1-1.el6 for package: wine-pulseaudio-1.4.1-1.el6.i686
--> Processing Dependency: alsa-plugins-pulseaudio(x86-32) for package: wine-pulseaudio-1.4.1-1.el6.i686
---> Package wine-pulseaudio.x86_64 0:1.4.1-1.el6 will be an update
--> Processing Dependency: wine-alsa(x86-64) = 1.4.1-1.el6 for package: wine-pulseaudio-1.4.1-1.el6.x86_64
---> Package wine-small-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-small-fonts.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-symbol-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-symbol-fonts.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-system-fonts.noarch 0:1.2.3-1.el6 will be updated
---> Package wine-system-fonts.noarch 0:1.4.1-1.el6 will be an update
---> Package wine-twain.i686 0:1.2.3-1.el6 will be updated
---> Package wine-twain.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-twain.i686 0:1.4.1-1.el6 will be an update
---> Package wine-twain.x86_64 0:1.4.1-1.el6 will be an update
---> Package wine-wow.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine-wow.x86_64 0:1.4.1-1.el6 will be an update
--> Running transaction check
---> Package alsa-plugins-pulseaudio.i686 0:1.0.21-3.el6 will be installed
---> Package gstreamer.i686 0:0.10.29-1.el6 will be installed
---> Package gstreamer-plugins-base.i686 0:0.10.29-1.el6 will be installed
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0) for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libcdda_interface.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: liboil-0.3.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0) for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libvisual-0.4.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libcdda_paranoia.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoradec.so.1 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libgudev-1.0.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoraenc.so.1 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
---> Package wine-alsa.i686 0:1.4.1-1.el6 will be installed
---> Package wine-alsa.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-ms-sans-serif-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-openal.i686 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1 for package: wine-openal-1.4.1-1.el6.i686
---> Package wine-openal.x86_64 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1()(64bit) for package: wine-openal-1.4.1-1.el6.x86_64
---> Package wine-tahoma-fonts.noarch 0:1.4.1-1.el6 will be installed
--> Running transaction check
---> Package cdparanoia-libs.i686 0:10.2-5.1.el6 will be installed
---> Package libgudev1.i686 0:147-2.40.el6 will be installed
--> Processing Dependency: libudev = 147-2.40.el6 for package: libgudev1-147-2.40.el6.i686
--> Processing Dependency: libudev.so.0 for package: libgudev1-147-2.40.el6.i686
---> Package liboil.i686 0:0.3.16-4.1.el6 will be installed
---> Package libtheora.i686 1:1.1.0-2.el6 will be installed
---> Package libvisual.i686 0:0.4.0-9.1.el6 will be installed
---> Package wine-openal.i686 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1 for package: wine-openal-1.4.1-1.el6.i686
---> Package wine-openal.x86_64 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1()(64bit) for package: wine-openal-1.4.1-1.el6.x86_64
--> Running transaction check
---> Package libudev.i686 0:147-2.40.el6 will be installed
---> Package wine-openal.i686 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1 for package: wine-openal-1.4.1-1.el6.i686
---> Package wine-openal.x86_64 0:1.4.1-1.el6 will be installed
--> Processing Dependency: libopenal.so.1()(64bit) for package: wine-openal-1.4.1-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: wine-openal-1.4.1-1.el6.i686 (epel)
       Requires: libopenal.so.1
Error: Package: wine-openal-1.4.1-1.el6.x86_64 (epel)
       Requires: libopenal.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@NOTEBOOK /etc/yum.repos.d] yum update --skip-broken
Loaded plugins: fastestmirror, presto, security
Loading mirror speeds from cached hostfile
 * epel: mirror.pmf.kg.ac.rs
 * rpmforge: ftp.lug.ro
 * sl: ftp.scientificlinux.org
 * sl-security: ftp.scientificlinux.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wine.x86_64 0:1.2.3-1.el6 will be updated
---> Package wine.x86_64 0:1.4.1-1.el6 will be an update
--> Processing Dependency: wine-openal(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-openal(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
---> Package wine-capi.i686 0:1.2.3-1.el6 will be updated
---> Package wine-capi.x86_64 0:1.2.3-1.el6 will be updated

...bla-bla

--> Processing Dependency: wine-common = 1.2.3-1.el6 for package: wine-desktop-1.2.3-1.el6.noarch
--> Processing Dependency: wine-common = 1.2.3-1.el6 for package: wine-core-1.2.3-1.el6.i686
--> Processing Dependency: wine-common = 1.2.3-1.el6 for package: wine-core-1.2.3-1.el6.x86_64
--> Finished Dependency Resolution
Skip-broken could not solve problems
Error: Package: wine-openal-1.4.1-1.el6.i686 (epel)
       Requires: libopenal.so.1
Error: Package: wine-openal-1.4.1-1.el6.x86_64 (epel)
       Requires: libopenal.so.1()(64bit)
 You could try running: rpm -Va --nofiles --nodigest
[root@NOTEBOOK /etc/yum.repos.d] 
[root@NOTEBOOK /etc/yum.repos.d] rpm -Va --nofiles --nodigest
[root@NOTEBOOK /etc/yum.repos.d]

..and the same starts again if I yum update..

I can't install the

wine-openal.i686 : Openal support for wine
wine-openal.x86_64 : Openal support for wine

why??

I tryied to yum remove wine*..ok it removed all the wine* packages from my system, but... when I tried to yum install wine... the same error message with "Requires: libopenal.so.1"...came up..

I tried to:

rm -f /var/lib/rpm/__db*
rpm -vv --rebuilddb

but it didn't helped..

[root@NOTEBOOK /etc/yum.repos.d] ls
epel.repo           linux_signing_key.pub    mirrors-rpmforge-testing  sl.repo           virtualbox.repo
epel-testing.repo   mirrors-rpmforge         rpmforge.repo             sl.repo;502df2db
google-chrome.repo  mirrors-rpmforge-extras  sl-other.repo             sl.repo;502e1e13
[root@NOTEBOOK /etc/yum.repos.d] 

I primary use rpmforge, and epel is just this:

[root@NOTEBOOK /etc/yum.repos.d] cat epel.repo 
[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
includepkgs=nss-mdns wine* gparted cups-pdf 

Q: How can I resolve this problem?

===============================================

UPDATE: I tried to download the:

http://rpm.pbone.net/index.php3/stat/4/idpl/15175751/dir/scientific_linux_6/com/openal-soft-1.12.854-1.el6.x86_64.rpm.html
http://rpm.pbone.net/index.php3/stat/4/idpl/15174245/dir/scientific_linux_6/com/openal-soft-1.12.854-1.el6.i686.rpm.html

but it gives "Error 550" ... ...

So... I tried:

http://pkgs.org/centos-6-rhel-6/atrpms-i386/openal-soft-1.12.854-1.el6.i686.rpm/download/
http://pkgs.org/centos-6-rhel-6/epel-x86_64/openal-soft-1.12.854-1.el6.x86_64.rpm/download/

"rpm -i"-ed the two rpm packages (these packages provided the libopenal.so.1's..), then:

[root@NOTEBOOK /etc/yum.repos.d] yum install wine
Loaded plugins: fastestmirror, presto, security
Loading mirror speeds from cached hostfile
 * epel: mirror.pmf.kg.ac.rs
 * rpmforge: ftp.lug.ro
 * sl: ftp1.scientificlinux.org
 * sl-security: ftp1.scientificlinux.org
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package wine.x86_64 0:1.4.1-1.el6 will be installed
--> Processing Dependency: wine-wow(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-twain(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-twain(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-pulseaudio(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-pulseaudio(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-openal(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-openal(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-ldap(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-ldap(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-fonts = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-desktop = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-core(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-core(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-cms(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-cms(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-capi(x86-64) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Processing Dependency: wine-capi(x86-32) = 1.4.1-1.el6 for package: wine-1.4.1-1.el6.x86_64
--> Running transaction check
---> Package wine-capi.i686 0:1.4.1-1.el6 will be installed
---> Package wine-capi.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-cms.i686 0:1.4.1-1.el6 will be installed
---> Package wine-cms.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-core.i686 0:1.4.1-1.el6 will be installed
--> Processing Dependency: wine-common = 1.4.1-1.el6 for package: wine-core-1.4.1-1.el6.i686
--> Processing Dependency: libgstreamer-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
--> Processing Dependency: libgstbase-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
--> Processing Dependency: libgstapp-0.10.so.0 for package: wine-core-1.4.1-1.el6.i686
---> Package wine-core.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-desktop.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-fonts.noarch 0:1.4.1-1.el6 will be installed
--> Processing Dependency: wine-tahoma-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-system-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-symbol-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-small-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-ms-sans-serif-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-marlett-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
--> Processing Dependency: wine-courier-fonts = 1.4.1-1.el6 for package: wine-fonts-1.4.1-1.el6.noarch
---> Package wine-ldap.i686 0:1.4.1-1.el6 will be installed
---> Package wine-ldap.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-openal.i686 0:1.4.1-1.el6 will be installed
---> Package wine-openal.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-pulseaudio.i686 0:1.4.1-1.el6 will be installed
--> Processing Dependency: wine-alsa(x86-32) = 1.4.1-1.el6 for package: wine-pulseaudio-1.4.1-1.el6.i686
--> Processing Dependency: alsa-plugins-pulseaudio(x86-32) for package: wine-pulseaudio-1.4.1-1.el6.i686
---> Package wine-pulseaudio.x86_64 0:1.4.1-1.el6 will be installed
--> Processing Dependency: wine-alsa(x86-64) = 1.4.1-1.el6 for package: wine-pulseaudio-1.4.1-1.el6.x86_64
---> Package wine-twain.i686 0:1.4.1-1.el6 will be installed
---> Package wine-twain.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-wow.x86_64 0:1.4.1-1.el6 will be installed
--> Running transaction check
---> Package alsa-plugins-pulseaudio.i686 0:1.0.21-3.el6 will be installed
---> Package gstreamer.i686 0:0.10.29-1.el6 will be installed
---> Package gstreamer-plugins-base.i686 0:0.10.29-1.el6 will be installed
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0) for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libcdda_interface.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: liboil-0.3.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0) for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libvisual-0.4.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libcdda_paranoia.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoradec.so.1 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libgudev-1.0.so.0 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
--> Processing Dependency: libtheoraenc.so.1 for package: gstreamer-plugins-base-0.10.29-1.el6.i686
---> Package wine-alsa.i686 0:1.4.1-1.el6 will be installed
---> Package wine-alsa.x86_64 0:1.4.1-1.el6 will be installed
---> Package wine-common.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-courier-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-marlett-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-ms-sans-serif-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-small-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-symbol-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-system-fonts.noarch 0:1.4.1-1.el6 will be installed
---> Package wine-tahoma-fonts.noarch 0:1.4.1-1.el6 will be installed
--> Running transaction check
---> Package cdparanoia-libs.i686 0:10.2-5.1.el6 will be installed
---> Package libgudev1.i686 0:147-2.40.el6 will be installed
--> Processing Dependency: libudev = 147-2.40.el6 for package: libgudev1-147-2.40.el6.i686
--> Processing Dependency: libudev.so.0 for package: libgudev1-147-2.40.el6.i686
---> Package liboil.i686 0:0.3.16-4.1.el6 will be installed
---> Package libtheora.i686 1:1.1.0-2.el6 will be installed
---> Package libvisual.i686 0:0.4.0-9.1.el6 will be installed
--> Running transaction check
---> Package libudev.i686 0:147-2.40.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libudev-147-2.40.el6.i686 != libudev-147-2.41.el6.x86_64
Error: Protected multilib versions: libgudev1-147-2.40.el6.i686 != libgudev1-147-2.41.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@NOTEBOOK /etc/yum.repos.d] 
[root@NOTEBOOK /etc/yum.repos.d] rpm -qa | grep -i libudev
libudev-147-2.41.el6.x86_64
[root@NOTEBOOK /etc/yum.repos.d]

...so now I got a:

Error: Protected multilib versions: libudev-147-2.40.el6.i686 != libudev-147-2.41.el6.x86_64 Error: Protected multilib versions: libgudev1-147-2.40.el6.i686 != libgudev1-147-2.41.el6.x86_64

error message... what to do next?? how can I fix this??

share|improve this question
    
plz somebody help :) –  gasko peter Sep 5 '12 at 15:19
    
Why is your libgudev protected? –  Nils Sep 6 '12 at 20:31
    
I don't know, but the problem still exists. –  gasko peter Sep 11 '12 at 5:45
add comment

1 Answer

up vote 1 down vote accepted

AFAIK fully enabling epel repo (commenting: includepkgs=nss-mdns wine* gparted cups-pdf) solves the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.