Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to start writing some simple plasmoids. However I am unable to use K-objects in QtCreator or KDevelop. I likely do not have the required libraries / SDK. How do I install it, or if I already have them, how do I make the mentioned IDEs aware of it?

share|improve this question

put on hold as off-topic by Jeff Schaller, Kusalananda, Networker, Archemar, sam yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Kusalananda, Networker, Archemar, sam
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do you just not see them or they error out? – Karlson Oct 12 '12 at 20:12
    
@Karlson, I do not know enough to understand or answer that question. – missingfaktor Oct 12 '12 at 21:10
    
When you launch QtCreator you could see widgets for KDE and when you try to use them QtCreator errors? Or you can't see them at all. – Karlson Oct 13 '12 at 13:18
    
@Karlson, after looking around a bit I found a way to let QtCreator know of the KDE dependencies. (I don't recall the details; sorry.) And then I tried running some rudimentary code samples from KDE Techbase. They worked except that I had to change all #include <KStuff> to #include <kstuff.h>. I wonder if I have an older version of KDE libs installed. Or maybe Techbase documentation is not up to date. – missingfaktor Oct 13 '12 at 18:35