Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Sony E Series laptop with Fedora 17 and Windows 8 in dual boot. The brightness adjusts just fine on my Windows8 but not in Fedora. If I change it with the brightness slider in the power settings nothing happens. The brightness stays maximum even if I adjust the slider to minimum.

Blinded by my screen and frustrated by the draining battery I tried everything on the net.

I tried things like -

  1. Reinstall bash. yum reinstall bash
  2. Add this to kernel parameters in grub2.cfg - acpi_backlight=vendor
  3. Add this line to xorg.conf - Option "RegistryDwords" "EnableBrightnessControl=1"
  4. Add this line to grub.cfg - "video.brightness_switch_enabled=1"
  5. Update the drivers for your video card.
  6. Install some utility. Example - xbacklight utility from freedesktop.org

None of these suggestions worked for me. I finally found the solution that worked and am sharing it in Q/A format for the benefit of others.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Issue the command - echo 500 > /sys/class/backlight/intel_backlight/brightness

Replace 500 with a number of your choice.

Don't take a number below 100 as that may (and probably will) turn off your screen.

Just take multiples of 100 from 500 (which is a reasonable low) to 4000 (this max may be different depending on your laptop model).

You'll need root access to execute this command.

share|improve this answer
    
Does this work in Lubuntu 11.10? I'd tried but the file contains the same value, 4882. Should I reboot the system? –  Sigur Sep 1 '12 at 23:30
    
I have these 2 folders: acpi_video0 intel_backlight –  Sigur Sep 1 '12 at 23:37
    
@Sigur What does it say when you try to change the value? You need to issue that command as root user. Type su at the terminal and enter the root password. –  Kshitiz Sharma Sep 2 '12 at 2:57
    
Well, nothing happens. I am using sudo echo .... and after the password, nothing wrong. No errors. but when I use cat /sys/.... to check the value, it is the same, 4882. –  Sigur Sep 2 '12 at 14:39
    
Hello. I found the answer. Using sudo does not work. But with sudo su first to change to root and then... aha! It works! Thanks. –  Sigur Sep 2 '12 at 18:58
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.