Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

One day the power just went off when was using my desktop computer running Ubuntu 11.04. When later the power came back, I couldn't access the internet.

When I open any browser, it tells me I have no connection. Even my desktop network icon shows that I am offline. But when I check the wired connection behind my desktop computer, it shows that I connected with a green blinking LED.

What is going on with my desktop? All the computers in our lab are fine. Only mine which I use to administer our computer lab has this problem.

  1. When I run the iconfig command this is what I get:

    eth0      Link encap:Ethernet  HWaddr b8:ac:6f:37:0d:58  
              inet6 addr: fe80::baac:6fff:fe37:d58/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2759 errors:0 dropped:0 overruns:0 frame:0
              TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:479931 (479.9 KB)  TX bytes:6608 (6.6 KB)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:118 errors:0 dropped:0 overruns:0 frame:0
              TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:13086 (13.0 KB)  TX bytes:13086 (13.0 KB)
    
  2. And when I run the route -n command, this is what I get:

    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    
share|improve this question
3  
What linux distro is that? (There is no such thing as "Linux 11.4". Is it OpenSUSE?) –  Mat Sep 1 '12 at 11:50
    
How is the network normally set up? What does Network Manager say? Post the output of ifconfig and route -n (run these commands in a terminal, copy-paste the output). –  Gilles Sep 1 '12 at 23:19
    
The route info didn't make it to your edit. Please include it again. (And don't retype/copy the whole contents of your post like you just did - make sure it looks ok in the preview window below the editor.) –  Mat Sep 3 '12 at 11:46
1  
Just blinking doesn't mean it's "connected" from a network manager. –  warl0ck Sep 3 '12 at 13:33
    
So apparently you are not getting any IP from the router (or another DHCP server in the network). Either your network card was damaged by the power fault or there's somethign wrong with the network (unlikely): can you try the same machine in other network? –  Renan Sep 3 '12 at 21:18

1 Answer 1

It seems to be a problem with DNS because a line after HWaddr number is missed.

share|improve this answer
    
-1: DNS has nothing to do with the fact that eth0 doesn't seem to have an IP. –  Renan Sep 3 '12 at 18:11
    
I'm very sorried i try to say DHCP (not DNS). –  Shugendo Sep 3 '12 at 20:34
    
You can edit your own answer and fix it. –  Renan Sep 3 '12 at 20:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.