Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Lubuntu 11.10, and I use my console a lot. Today I discovered that its font was changed; specifically, this screen is from yesterday:


and this is from today:


First of all, any idea of how I changed it? I'm pretty sure I did nothing to justify this, but I'm also certain that if something happened there's always a reason, so...

Besides, how do I restore the previous font? The main issue is that I'm not sure what it was.

share|improve this question
My guess is that you hit a key combination that told the terminal to increase the font size. – Kyle Jones Aug 31 '12 at 17:53
As far as I can see there is no way to change the font size with a key combination; actually, as far as I can see the only way to change the font is by modifying something on grub, so, well, I'm kinda confident I didn't do anything like that. – Odexios Aug 31 '12 at 18:41
What files in /etc have been modified since the last reboot? Did you reboot since yesterday? What did you do before to set the console font: are you using a font on the graphic card, or the framebuffer? – Gilles Aug 31 '12 at 23:32
I have no idea if I'm using a font from the graphic card or the framebuffer; I'm googling right now to understand the difference, thoug. As far as I can see (i.e., as far as my find skills can see), no relevant files in /etc/ have been modified; I rebooted (is that right?) many times since when I wrote the post (one just after I saw that the font was different), and nothing changed. By the way, thank for the corrections in the post! Though I don't see why the "thanks" was to be removed. – Odexios Sep 2 '12 at 0:45

I'm wondering why you chose a bunch of dots and arrows to demonstrate a font instead of... you know... letters.

Anyway the command for changing font on the VTs is setfont or consolechars. Running setfont with no args or consolechars -d loads a "default" font. Others that you can load are found in /usr/share/consolefonts.

In Debian there's a file /etc/default/console-setup which the boot scripts use to decide what to do with the console font.

share|improve this answer
There's a reason I chose that particular screen, and I'd guess it wouldn't be hard to understand why I did it for anyone who would be actually interested in the matter; people don't usually make screenshot of a tty screen just to pass time. The only screen of my tty pre-change I have is one I took because it's from a program I wrote and I wanted to pass that screen to a friend. I'm sure you can see why the second screen is similar to the first one. Anyway, thanks for the answer, I'll look into the matter when I'm a little less drunk; it seems the right direction, though. Have a nice day. – Odexios Sep 2 '12 at 0:40
Of course, matching an old screenshot made for a different purpose makes sense – Alan Curry Sep 2 '12 at 0:45
Well, it was the only screenshot I had, not a lot of options to choose from. Anyway, let's be clear; there was no reason for you to be provocative, considering I'm pretty sure I didn't did anything to deserve it; and when you can choose between provocative and conciliatory, choosing the first one is almost always wrong. That said, setfont with no arguments echoes this message: Cannot find default fonts. I'd say that's not normal; what I found on google didn't help me, I'll search some more, though. Again, not trying to pick a fight, I'm grateful for the help; it's the style I don't like. – Odexios Sep 2 '12 at 0:55

You can use the reset command in bash to reset everything in your shell, such as color and so on.

share|improve this answer
I tried with a reset, but nothing changed. I tried with a reboot, too, but nothing changed. – Odexios Sep 2 '12 at 0:45
Oh ,So you didn't changed font already , and you want to change now ... ok? or default font deleted. – PersianGulf Sep 2 '12 at 11:50
up vote 0 down vote accepted

I don't know if kbd is installed by default or not, but though setfont worked, I didn't have it installed; a simple sudo apt-get install kbd did the trick, and the font is back to normal.

setfont still echoes Cannot find default font, though; I'm still trying to understand what's happened/what is happening.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.