Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install proxy software called Glype on my server. It continues to tell me that "Glype requires cURL/libcurl". I have the latest version of curl installed. Why might this be happening? Glype runs with PHP, and the curl binary is in /usr/bin and is rwxrwxrwx.

share|improve this question
5  
I know nothing about Glype, but maybe it requires libcurl? How exactly did you try to install Glype (what did you download, what commands did you run, etc.)? Do not make files rwxrwxrwx, it is never the answer. Don't change the permissions of a file if you don't understand why. –  Gilles Aug 30 '12 at 0:35
    
a link to a pastebin of the error might be nice :) –  Born2Smile Aug 30 '12 at 0:39
    
@Gilles It said it requires curl or libcurl. It's a bunch of php files in a folder, and you are supposed to run one for settings. –  tkbx Aug 30 '12 at 17:21

3 Answers 3

From your query and the tests you have done, it seems you have cURL installed in the first place and it looks pretty much like php is not able to find the curl path even though it is installed properly. troubleshoot it further by putting a phpinfo page in the doc root and see if php is taking the curl that is installed. if it does then you may need to check if curl is working as it should be. do a sample script that runs curl function and see if it gives any errors. I hope this helps.

share|improve this answer

I downloaded glype and found it's a PHP program, so what you need is not libcurl or CURL binary, but php_curl module,

apt-get install php5-curl should work for you.

If you're running php with apache, simply restart apache will finish the installation:

service apache2 restart

share|improve this answer
    
That should be php5-curl with a '-', not a '_'. Simply installing the package will enable the module, since php5 in debian uses a split configuration system. Apache will need to be restarted if mod_php is used though. –  jordanm Aug 31 '12 at 5:45
    
@jordanm updated, thanks –  warl0ck Aug 31 '12 at 5:46
1  
+1 for taking the time to look at the application and find the correct solution. –  jordanm Aug 31 '12 at 5:49

Please provide more info, such:

  • What distro are you using? (or *nix flavor)
  • Version of Glype

My recomendation is that you should install libcurl

E.g. in a Debian machine:

$ dpkg -l | grep curl
ii  curl                                 7.21.0-2.1+squeeze2                  Get a file from an HTTP, HTTPS or FTP server
ii  libcurl3                             7.21.0-2.1+squeeze2                  Multi-protocol file transfer library (OpenSSL)

Check if you have the library already installed with the command of dpkg stated above or since you are you're using Linux Mint, you should be able to install libcurl by issuing:

apt-get install libcurl3

Or you can use any other package available.

share|improve this answer
    
I'm using linux mint 13, newest glype (on the network I need glype for, so can't go to page to find the version). Libcurl is worth a try, but if either is supposed to work, I don't see why the lib would work and not the executable. –  tkbx Aug 30 '12 at 17:23
    
@lucase.62 I've edited my response, let us know if that solve your problem. –  alemani Aug 31 '12 at 4:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.