Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Is there any chance I can load binary codecs on 64bit arch linux ? I have few .dat files that works great under 32bit windows xp, with smplayer (after downloading codecs), but on 64bit Linux, I got twisted image.

I downloaded all binary codecs for win32 here,

And essential elf64 libs here

Both archive was extracted to /usr/lib/codecs

From output of strace, seems /usr/lib/codecs wasn't loaded.

P.S attached mplayer log

MPlayer SVN-r35014-4.7.1 (C) 2000-2012 MPlayer Team
195 audio & 404 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing avseq03.dat.
libavformat version 54.15.100 (internal)
MPEG-PS file format detected.
VIDEO:  MPEG1  352x288  (aspect 8)  25.000 fps  1120.0 kbps (140.0 kbyte/s)
Load subtitles in ./
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.33.100 (internal)
Selected video codec: [ffmpeg1] vfm: ffmpeg (FFmpeg MPEG-1)
==========================================================================
==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 44100 Hz, 2 ch, s16le, 224.0 kbit/15.87% (ratio: 28000->176400)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[VD_FFMPEG] Trying pixfmt=1.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[VD_FFMPEG] Trying pixfmt=2.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[swscaler @ 0xfbf060]BICUBIC scaler, from yuv420p to rgb24 using MMX2
VO: [xv] 352x288 => 384x288 Planar YV12  [zoom]
[mpeg1video @ 0xef7180]ac-tex damaged at 12 3
[mpeg1video @ 0xef7180]Warning MVs not available
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
A:   3.7 V:   3.2 A-V:  0.530 ct: -0.038  26/ 26  1%  0%  0.5% 0 0 
[mpeg1video @ 0xef7180]slice mismatch
[mpeg1video @ 0xef7180]Warning MVs not available
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
A:   3.7 V:   3.2 A-V:  0.526 ct: -0.034  27/ 27  1%  0%  0.5% 0 0 
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
A:   3.8 V:   3.3 A-V:  0.482 ct: -0.030  28/ 28  1%  0%  0.5% 0 0 
[mpeg1video @ 0xef7180]concealing 330 DC, 330 AC, 330 MV errors
A:   3.8 V:   3.3 A-V:  0.478 ct: -0.026  29/ 29  1%  0%  0.5% 0 0 
share|improve this question
add comment

2 Answers

Well, first, mplayer believes this to be mpeg1, which ffmpeg can handle just fine. Or at least, is supposed to be able to handle just fine, and normally mplayer prefers ffmpeg. You could attempt to force it to use a different decoder with -vfm or -vc options (pass "help" to either to get a list). You could also try a different -demuxer (also takes "help" for the list).

But I'm not sure that a 64-bit mplayer can load 32-bit codecs, anyway. There is a win64 codecs package you could try. Alternatively, you could install (possibly from source) a 32-bit mplayer.

share|improve this answer
    
And if the files aren't private, upload one for other people to try. A file that looks like plain mpeg but won't play in vanilla mplayer could be a bug that would be easy to fix when mplayer developers get their hands on the test case. –  Alan Curry Aug 29 '12 at 19:29
add comment

It will probably work with the ia32-libs package and a 32-bit version of mplayer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.