Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When postfix connects to the FQDN dur.bounceme.net it uses the external IP address:

root@dur:~# 
root@dur:~# tail /var/log/mail.log
Aug 28 04:39:45 dur postfix/master[6667]: terminating on signal 15
Aug 28 04:39:46 dur postfix/postfix-script[6781]: starting the Postfix mail system
Aug 28 04:39:46 dur postfix/master[6782]: daemon started -- version 2.9.1, configuration /etc/postfix
Aug 28 04:39:52 dur postfix/smtpd[6786]: connect from localhost[127.0.0.1]
Aug 28 04:40:37 dur postfix/smtpd[6786]: B92B518431A: client=localhost[127.0.0.1]
Aug 28 04:41:21 dur postfix/cleanup[6790]: B92B518431A: message-id=<20120828114037.B92B518431A@dur.bounceme.net>
Aug 28 04:41:22 dur postfix/qmgr[6784]: B92B518431A: from=<routing@dur.bounceme.net>, size=438, nrcpt=1 (queue active)
Aug 28 04:41:23 dur postfix/smtp[6792]: connect to dur.bounceme.net[70.71.113.158]:25: Connection refused
Aug 28 04:41:23 dur postfix/smtp[6792]: B92B518431A: to=<thufir@dur.bounceme.net>, relay=none, delay=62, delays=60/0.02/1.6/0, dsn=4.4.1, status=deferred (connect to dur.bounceme.net[70.71.113.158]:25: Connection refused)
Aug 28 04:41:26 dur postfix/smtpd[6786]: disconnect from localhost[127.0.0.1]
root@dur:~# 

What's causing the FQDN to behave this way?

Can I, and should I, and how would I, configure dur.bounceme.net to resolve to 127.0.0.1?

share|improve this question
1  
Because dur.bounceme.net resolves to 70.71.113.158 –  Ulrich Dangel Aug 28 '12 at 12:54
1  
Make sure your postfix is correctly configured, especially the parameter mydestination. See postfix.org/postconf.5.html#mydestination –  angus Aug 28 '12 at 21:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.