Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've installed power saving packages (bumblebee, laptop-mode-tools, and cpufreq) to my laptop with Debian Wheezy. Thanks to that I decrease power usage from 32W to 10W. But now I faced the issue that I can't disable touchpad. I wrote simple script that inverts state of touch-pad:

#!/bin/sh
synclient TouchpadOff=`synclient | grep TouchpadOff | awk '{print !$3}'`

When I launch this script, it inverts state of touch-pad as expected, but in 5 seconds TouchpadOff is rewritten with value "2", and touch-pad becomes active again.

I suppose that it's laptop-mode-tools who modifies TouchpadOff variable. I tried to find related settings in laptop-mode-tools, but didn't find anything.

Any ideas how to determine who modifies TouchpadOff variable and how to disable such a modification?

share|improve this question
    
Does it happen also on a second run of the script? Eg. is something continuously enabling the touchpad? –  lynxlynxlynx Aug 25 '12 at 16:46
    
Yes, it enables touchpad continuously. –  Dmitriy Sukharev Aug 25 '12 at 19:20
    
I think this might have to do with the USB autosuspend feauture of laptop-mode-tools. Have you tried disabling it? This is pretty much a wild guess but I would start investigating laptop-mode-tools. –  Silverrocker Oct 29 '12 at 16:54
    
As far as I remember I tried to disable autosuspend mode of USB, but it didn't change anything. I workarounded my problem by "disabling mouse clicks with touchpad". It doesn't make the script works, but makes the whole thing less annoying. –  Dmitriy Sukharev Oct 29 '12 at 20:10
    
Did you try to uninstall laptop-mode-tools to see if your touchpad is still activating after that ? (I mean, are you sure it comes from laptop-mode-tools ?) –  Depado Jan 8 '13 at 8:31
show 2 more comments

1 Answer

I resolved my issue without disabling touchpad. The original issue was that I touched my touchpad area by my palms clicking controls that I didn't wanna click. My previous laptop had Fn hot key to disable touchpad, but it doesn't work in my current laptop, therefore I decided to write the script to disable it, that finally lead me asking the question here.

But actually I have Buttonless TouchPad (aka ClickPad). Having it I can change the mode of clicking at UI components in Linux. Available options are click by touch and click by click on clickpad. I had click by touch option selected. And of course it was very annoying to have the focus changed all the time I type something, especially taking into account that my ClickPad is very big.

So how to switch to clicking at UI components by click on ClickPad? I have Gnome 3, but the idea should be the same in Unity, and probably some others. Go to System Settings, select 'Mouse and Touchpad' item there. Go to the 'Touchpad' tab and deselect 'Enable mouse clicks with touchpad' checkbox. That's it :)

Unfortunately there are still the cases when this solution won't be acceptable for you. For instance if you have TouchPad (not ClickPad) or if your ClickPad is hard to press. In this cases it would be suitable to disable touchpad programmatically. Therefore I leave this question unanswered.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.