Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to run sensors-detect in Debian6 64 bits and I get:

Sorry, no sensors were detected. Either your system has no sensors, or they are not supported, or they are connected to an I2C or SMBus adapter that is not supported.

Sensors applet is correctly running as well as sensor cpu


    root@debian:/# dmesg | grep -i error 
[ 0.558964] ACPI Error (psargs-0359): [RAMB] Namespace lookup failure, AE_NOT_FOUND 
[ 7.537292] PM: Error -22 checking image file 
[ 9.581500] nouveau: probe of 0000:01:00.0 failed with error -22

root@debian:/# lspci
00:00.0 Host bridge: Intel Corporation Sandy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Sandy Bridge PCI Express Root Port (rev 09)
00:02.0 Display controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation Cougar Point HECI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 1 (rev b5)
00:1c.5 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1d.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Cougar Point LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation Cougar Point 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation Cougar Point SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation Device 1244 (rev a1)
01:00.1 Audio device: nVidia Corporation Device 0bee (rev a1)
03:00.0 USB Controller: Device 1b21:1042
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
05:00.0 PCI bridge: Device 1b21:1080 (rev 01)

I only get the following running sensors:

root@debian:/# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:       +27.8°C  (crit = +99.0°C)                  
temp2:       +29.8°C  (crit = +99.0°C)

With this proposed script (http://dl.lm-sensors.org/lm-sensors/files/sensors-detect) It seems that sensors-detect find much more, I restart Debian, or I start the service lm-sensor and I get the same outpout at sensors

share|improve this question
    
If the sensors are already working then why do you care if the detect script fails? –  Alan Curry Aug 22 '12 at 21:18
    
The applet shows more than the command line sensors? –  Alan Curry Aug 22 '12 at 21:32
    
Was that an answer to my question? –  Alan Curry Aug 22 '12 at 21:36
    
That's very confusing. The applet and the command use the same backend, don't they? In any case... try the updated script from dl.lm-sensors.org/lm-sensors/files/sensors-detect since the one in Debian is older than your CPU. –  Alan Curry Aug 22 '12 at 21:48
    
The sensors-detect script only suggests modules to load. You have to put them in /etc/modules yourself. –  Alan Curry Aug 22 '12 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.