Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd like to set a custom motd ("message of the day") on my machine (currently Mac OS X 10.6.5 using Bash with Terminal.app).

In /etc/ there was no motd file so I created one with some sample text. But the message doesn't show up when I restart Terminal. I've tried to logout and then login but it still doesn't seem to kick in.

If I do ls -l /etc/motd I get (if it's any clue):

-rw-r--r-- 1 root wheel 30 7 Dec 11:58 /etc/motd

Am I missing something?

share|improve this question

Seems I worked it out. My motd not showing up must have been due to the fact that I had touched/added an empty file in my home directory called .hushlogin, which actually supresses any login messages (seems it doesn't just kill motd but any other login messages as well, as I understand it). At any rate, my problem is somehow solved and chances are I forgot to delete that .hushlogin file.

share|improve this answer

Depending on your distribution, the system may create a new motd automatically on each startup. Ubuntu seems to be doing that at least.


share|improve this answer
Yes, that may be the case with my distro as well (Darwin/BSD). At there is this "Last login: Tue Dec 7 16:10:04 on ttys000" message each time I fire up a new Terminal frame. – Henrik Dec 7 '10 at 19:22
An empty .hushlogin file in your ~ dir will hide any motd and the message I mentioned in my prev. comment above. – Henrik Dec 11 '10 at 3:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.