Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I am writing for some help regarding Postfix configuration.

I cannot seem to get Postfix configured properly to transfer mail to the mailing list installed on the same server. I followed many steps over the last few days, and the last one I followed is at under the section Mailing Lists.

Can someone please look at this and let me know what I am missing?

Basically, Postfix has been configured for base email to be sent to and I would like the mail list to use

**DYN-DNS**        A        MX        TXT     "v=spf1 a ptr mx ip4: -all"       A       MX       TXT     "v=spf1 a ptr mx ip4: -all"

myhostname =
mydomain =
myorigin = $hostname
alias_maps = hash:/etc/aliases, hash:/etc/mailman/aliases
alias_database = hash:/etc/aliases, hash:/etc/mailman/aliases 
recipient_delimiter = +
virtual_alias_maps = hash:/etc/postfix/virtual 
mydestination = $myhostname, listtest.$mydomain

/etc/postfix/virtual:   listname-request               listname     owner-listname

    listname: "/usr/lib/mailman/mail/mailman post mailman"
    owner-listname: ...
    listname-request: ...

MTA = 'Postfix'

The first part of the log shows the rejection of -- whereas the second part shows successful transfer to


Aug 17 15:46:50 listserv postfix/smtpd[19870]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 <>: 
Relay access denied; from=<user@company1.ORG> to=<> 
proto=SMTP helo=<>
Aug 17 15:46:50 listserv postfix/cleanup[19877]: D3F93209F1: message-
Aug 17 15:46:50 listserv postfix/smtpd[19870]: disconnect from[]

Aug 17 15:46:50 listserv postfix/qmgr[19197]: D3F93209F1: 
from=<user2@company.ORG>, size=6670, nrcpt=1 (queue active)
Aug 17 15:46:50 listserv postfix/cleanup[19877]: F37B120A3B: message-
Aug 17 15:46:51 listserv postfix/qmgr[19197]: F37B120A3B: 
from=<user2@company.ORG>, size=6819, nrcpt=1 (queue active)
Aug 17 15:46:51 listserv postfix/local[19878]: D3F93209F1:
to=<>, relay=local, delay=0.18,
delays=0.17/0.01/0/0, dsn=2.0.0, status=sent (forwarded as F37B120A3B)
Aug 17 15:46:51 app02-listserv postfix/qmgr[19197]: D3F93209F1: removed

Any help would be greatly appreciated.

share|improve this question

2 Answers 2

I added mailman to my working postfix setup by following the instructions here: I think this will work well for you because I also use a different subdomain for from the primary domain.

share|improve this answer

It was a config problem with the virtual alias table. Once corrected, and POSTALIAS run, it is now forwarding email correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.