Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This error occurs to me when i install freetds on centos Machine. What is the problem??

This is Error appears when i installed freetds i installed unixODBC but with version 64 bit

How can i Solve this problem

[root@localhost portal]# yum install freetds
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base: mirror.crazynetwork.it
 * epel: mirror01.th.ifl.net
 * extras: mirror.crazynetwork.it
 * rpmforge: be.mirror.eurid.eu
 * updates: mirror.crazynetwork.it
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package freetds.i386 0:0.91-2.el5 will be installed
--> Processing Dependency: libtermcap.so.2 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libreadline.so.5 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libodbcinst.so.1 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libodbc.so.1 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libgnutls.so.13 for package: freetds-0.91-2.el5.i386
--> Running transaction check
---> Package compat-libtermcap.i686 0:2.0.8-49.el6 will be installed
---> Package compat-readline5.i686 0:5.2-17.1.el6 will be installed
---> Package freetds.i386 0:0.91-2.el5 will be installed
--> Processing Dependency: libodbcinst.so.1 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libodbc.so.1 for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package: freetds-0.91-2.el5.i386
--> Processing Dependency: libgnutls.so.13 for package: freetds-0.91-2.el5.i386
--> Finished Dependency Resolution
Error: Package: freetds-0.91-2.el5.i386 (epel)
           Requires: libodbc.so.1
Error: Package: freetds-0.91-2.el5.i386 (epel)
           Requires: libgnutls.so.13
Error: Package: freetds-0.91-2.el5.i386 (epel)
           Requires: libodbcinst.so.1
Error: Package: freetds-0.91-2.el5.i386 (epel)
           Requires: libgnutls.so.13(GNUTLS_1_3)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
share|improve this question

migrated from stackoverflow.com Aug 12 '12 at 14:08

This question came from our site for professional and enthusiast programmers.

    
well solve your dependencies first one by one .. –  MimiEAM Aug 12 '12 at 11:05
    
how to solve dependencies sorry i'm new in centos –  Ahmed Hosni Aug 12 '12 at 11:09

1 Answer 1

It appears you've installed the EPEL repository for RHEL 5 instead of for RHEL 6. Go back to EPEL and install the epel-release RPM for RHEL 6.

share|improve this answer
    
And while you're at it, set rpmforge to not be enabled by default. They're a major source of dependency hell and version conflicts when not used with care. –  Charles Aug 12 '12 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.