Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running KDE in Debian Testing and I just noticed that the system is really quiet. This is my office laptop, so to be honest I turned the sound on for the first time since I got it 2 years ago.

The system sound in KMix is 100%, but still pretty much all the sounds are rather quiet. How can I make it louder?

share|improve this question
    
Laptop doesn't have an external volume mechanic like a dial or something does it? If not, then maybe the driver is not quite up to snuff. –  Tim Aug 10 '12 at 20:10
    
The only sound related buttons I could find operate the volume in KDE... –  Grzenio Aug 10 '12 at 20:11
    
Check out alsamixer and amixer. –  Emanuel Berg Aug 10 '12 at 21:49

1 Answer 1

up vote 2 down vote accepted

This depends on your audio setup. Let's assume you basically just have alsa up and running and phonon (kde's abstraction of your sound system) connects to alsa. You can check if this is the case by looking at you kmix. When you open the mixer, you will see many channels. In this case, you'd just open a terminal and type in alsamixer. This will open up a text equalizer. Check if the relevant channels are turned up. You may find that one of the outputs is only turned up halfway or so. Use arrow keys to turn them up and hit esc to exit. To make this permanent, you'd (as root) do alsactl store and have the alsa daemon running at bootup to restore the volume levels. Even if you don't kmix will restore it in your kde session.

If on the other hand, you use pulseaudio (you should see only one channel in the kmix mixer in this case), the answer is a little out of my league. Technically, doing the alsamixer trick should still work, but I'm not completely aware of how pulseaudio relates to alsamixer settings. Try the alsamixer route and see if it fixes the problem. It's a good first step.

share|improve this answer
    
Alsamixer only shows master channel called Pulseaudio... I am wondering how to configure pulseaudio directly... –  Grzenio Aug 29 '12 at 15:11
    
That's fine. That means your audio set up is something like this: alsa -> pulseaudio -> phonon -> kde In alsamixer, look on the top right. There's a way to pick the sound card. I think the shortcut is F5 or F6. Use that to pick your sound card and you should see several channels. Now, make sure they're maxed out. That should fix it. –  karthikp Dec 10 '12 at 5:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.