Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After running bash commands(e.g !mv file1 file2) vim outputs result of that command and prints this message:

Press Enter or type command to continue

Is there a way to skip this message and return to vim automatically?

share|improve this question
2  
This has already been discussed: stackoverflow.com/questions/890802/… – intelfx Aug 10 '12 at 14:40
up vote 3 down vote accepted

I don't think you can disable it, but you could use a mapping and append <CR>:

map <F4> :!mv file1 file2<CR><CR>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.