Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a dedicated server running Centos 6.3. My customer wants to use Microsoft Outlook to send and receive e-mails. He can connect and receive his mails but when he tries to send e-mail he can't because in Turkey SMTP outgoing port 25 is blocked. I need to change the SMTP outgoing port to 587. How can I change it on my server allow mail to be sent?

share|improve this question
    
Thanks @uther for the right syntax ;) –  Murat Aug 9 '12 at 15:46
    
What email client is your customer using? You'd need to change it there. –  jsbillings Aug 9 '12 at 16:23
    
@jsbillings you got it wrong. If i change outgoing port from 25 to 587. when i check Mail Queue on my server, i get this message : Messages in queue: 3 deferred so i need to change smtp outgoing port on my server to be delivered –  Murat Aug 9 '12 at 16:43
    
witout any additional information like smtp server we can't help. And you don't need to change the SMTP outgoing port but your smtp server should listen on 587 (which is nowadays pretty common anyway) as well –  Ulrich Dangel Aug 9 '12 at 16:52
    
@UlrichDangel i edited my etc/postfix/master.cf file : #smtp inet n - n - - smtpd i omitted this line and added : 587 inet n - n - - smtpd -o content_filter=spamassassin My smtp server is Postfix running on Centos 6.3 i am using Plesk 11.0.9 –  Murat Aug 9 '12 at 16:58
show 1 more comment

1 Answer

up vote 3 down vote accepted

What you're actually doing is asking how to set the ports used Postfix so that it is also listening on tcp/587, which is the "submission" port.

I have the following in my /etc/postfix/master.cf:

submission inet n       -       n       -       -       smtpd
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING

The first column of the first line specifies the service (e.g., the port from /etc/services), listening as an Internet service, using the smtpd command. The various "-o" lines are the options on the smptd command, which specify encryption, SASL authentication, etc. So, my Postfix server will listen on port 587, with SSL and client authentication required.

Your customer will need to adjust his Outlook settings so that the connection is to tcp/587 (Outlook is what we would usually say is outgoing, as the client initiates the connection; the connection for Postfix would be termed incoming), turn on SSL and authenticate against the server.

share|improve this answer
    
thank you. i only added this line 587 inet n - n - - smtpd and it worked. thanks again for the solution. –  Murat Aug 17 '12 at 15:03
    
Hmm. I make sure you haven't created an open relay. The other lines in my configuration have to do with turning on SSL and authentication. You may be doing this elsewhere in your config but you should check that you haven't left yourself too open. –  cjc Aug 17 '12 at 17:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.