Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I normally enjoy using Gnome 3 and gnome-shell in Fedora 16. However, I would like to temporarily run a non-compositing window manager such as metacity so that some wine games can have full control of the display.

I have metacity installed. When I run metacity --replace, instead of switching window managers I get a gnome-shell failure display that forces me to logout.

I also cannot find a way to choose a different session from the login prompt. There are no buttons, options, arrows or anything to choose. Just username and password.

I'm about to resort to desperate measures involving systemd runlevels to disable X and start it manually via startx. Is that going to be my only option? I hope not.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

No. However ambitious and great your idea about halting runlevels, you need not do that. Once you are logged into your GNOME system, switch to TTY1 using 'ctrl + Alt + F1'. There enter the following command:

$ xinit metacity -- :1

This will launch metacity on Screen 1. If you want you can also end your GNOME session before doing this.

share|improve this answer

If you use GDM, there next to the user and password a small arrow where you can choose the X dm you have installed and want to use. So closing session and choosing that WM should work.

share|improve this answer
    
This does not actually work because GDM seems to only detect full desktop environments, not window managers. –  Zan Lynx Oct 10 '12 at 18:45
2  
@ZanLynx - You can create a .desktop file for whatever you use. I use xmonad fine with GDM. –  tjameson Mar 25 '13 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.