Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I wanted to check a CD from my drawer. I inserted it into my drive and issued mount. I got

mount: block device /dev/sr0 is write-protected, mounting read-only

mount command did not exit. I checked its state in top:

4640 root      20   0 27088 1280 1060 R  99,8  0,0   1:36.90 mount

99,8% CPU usage what was not true because usage of all my cores is almost 0,0%. I tried to kill it - no success (both signals KILL and TERM fail to stop the mount programme). I tried reboot -f and reboot got into D state. fuser helped neither. /dev/sr0 is my cdrom and it was not present in mount output

umount  /media/cdrom 

umount: /media/cdrom0 is not mounted (according to mtab)

fstab:

/dev/sr0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Don't know what to do with that. All what works is to cut power and start again. System doesn't reboot or shutdown.

share|improve this question
1  
Switching to a different a pty and explicitly killing the process also unsuccessful? Just has similar behavior from a USB device that still showed as mounted, but all attempts to access it errored out with "Input/Output Error". I had to dismount it first. –  Tim Aug 8 '12 at 17:50
    
If u mean Ctrl+C in terminal (tty) or terminal emulator in X, then all I get is '^C' with no influence on mount. –  lord.didger Aug 8 '12 at 18:33
    
No, I mean pressing alt+3 or ctrl+alt+3 to switch from TTY1 to TTY3. –  Tim Aug 8 '12 at 18:37
    
Any use of kill with or without options failed to kill the mount command –  lord.didger Aug 8 '12 at 19:20

1 Answer 1

Not sure what the actual question is, but if it's "how do I figure out what's going on", the output of the dmesg command is likely your best bet, as it's where the kernel would display any read errors or any other available debug info.

If your question is instead "how do I read this disc", you could use a tool like GNU ddrescue to read the raw sectors from the disk into an image file. This would let you know if it's failing to read the physical disk (bad sectors) rather than failing to interpret the data (corrupted filesystem), and it would be easier to experiment with different ways of recovering your data from the generated image.

share|improve this answer
    
My problem is that I can't fully control my system. There is the procedure I described that reveals u can create a process u can't kill. I found somewhere on the net you should unmount a device but the solution is not relevant to my case. In short: how to kill that mount programme? –  lord.didger Aug 8 '12 at 20:25
    
That would fall under the "how do I figure out what's going on" umbrella. Run dmesg and see what it says -- if you can't kill a program that's behaving as you described, it's almost certainly stuck in the kernel somewhere. This may be due to a kernel bug, or hardware that is not responding (in this case, possibly because the disc is bad) –  Jim Paris Aug 9 '12 at 2:13
    
I guess I do sth wrong because there is no new output from dmesg when I mount the disc. –  lord.didger Aug 10 '12 at 14:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.