Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How do I format my external hard drive to a very Linux compatible file system?

share|improve this question
    
possible duplicate of Most unix-like filesystem that can be mounted under windows and Mac OS X –  Mat Aug 8 '12 at 15:13
    
He doesn't need Windows compatibility –  darnir Aug 8 '12 at 15:36
    
No, that's not a duplicate, this one doesn't require compatibility on OS other than linux. –  warl0ck Sep 8 '12 at 1:07

2 Answers 2

up vote 4 down vote accepted

You could use GUI applications like GParted on Ubuntu. Install them from the repositories using:

sudo apt-get install gparted

Once you have it installed, select the correct block device/partition and format it using a filesystem like ext2/3/4, JFS, XFS, ResiserFS, etc depending on your needs.

However, the above mentioned file systems are only for reference. Not all of them run on all distributions perfectly.

For example, as @Nils pointed out:

RiserFS is not suppported any more on some major distributions.
JFS and XFS can be too new for some distributions. Ext2 is too old.

Ext2 is almost a legacy file system now and not a very good choice.

That leaves only Ext3 and Ext4.

Again, since ext4 is still new and under development, it may have problems with a few distributions. For example, on RH5 there is no ext4, on SLES10 it is a bit dicey. However, I should point out here that the vanilla Linux kernel completely supports ext4 since version 2.6.28. On Arch and Gentoo ext4 gives no problems.

But ext3 will work an any current distribution - not only the newest ones.

share|improve this answer
    
I get 'You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies:' and when i run 'apt-get -f install' as they suggest, i get a bunch of waiting and then 'connection timed out' message. –  Hermann Ingjaldsson Aug 8 '12 at 15:30
    
It seems like you are not connected to the internet on that machine. And your apt-get is possibly broken. I am no Debian expert to be able to help you there. –  darnir Aug 8 '12 at 15:37
    
Have your previously added any PPA's and then removed them? That seems to be the most common cause for the above error. Also, run 'sudo apt-get -f install'. It seems many people tend to forget adding the sudo. –  darnir Aug 8 '12 at 15:47
    
I ran it with a sudo, the solution in the end was to go to a friends house and format it there with the ubuntu gui. But this answer is a useful future reference. –  Hermann Ingjaldsson Aug 8 '12 at 19:15
    
RiserFS is not suppported any more on some major distributions. JFS and XFS can be too new for some distributions, ext2 is too old. My best bet is good old ext3. –  Nils Aug 8 '12 at 20:08

Since it is an external drive, you might want to format with Fat32 or NTFS, so you access the files when moving the disk around to different platforms.

As darnir said, Gparted is a suitable tool for this.

share|improve this answer
    
ntfs is tricky on some distributions. Fat32 does not support files larger than 2 GB - but Fat32 is supported on any Linux I know of. –  Nils Aug 8 '12 at 20:09
    
If one is using linx for most part of their work, ntfs is a terrible choice to go for. the ntfs-3g driver is still not complete or perfectly stable. And r/w speeds are nowhere close to what other filesystems can provide. FAT on the other hand has the file size limit. exFat though is a good option to choose. –  darnir Aug 9 '12 at 19:49
    
100% would prefer Ext3/4 myself, but like I mentioned in my answer, if you are moving your disk around between platforms, you might want to consider the crappier MS alternatives for portability. –  Tim Aug 10 '12 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.