Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using an NTFS parition for storing data I like to access both from Ubuntu and Windows 7. On my Ubuntu HOME partition, I like to link the folder Assets in order to access it from an application running on Ubuntu. Therefore, I created the following link.

ln -s /media/data/Assets/ ~/bin/SomeJavaApp/data/assets

When I try to access the data within the application, the following error message appears.

Error message: Could not acquire data access

The NTFS parition is attached via auto mount in /etc/fstab. Here is the relevant configuration setting:

# Data partition auto mount.
UUID=159EBA47019D5D33 /media/data ntfs defaults,umask=007,uid=1000,gid=1000 0 0

My HOME partition is formatted with ext4. The application I use is written in Java. Is there something, I can do about this besides copying the files to the HOME partition?


I also get a Java error message when I start the application from the console.

java.lang.NullPointerException: Could not acquire data access

@Gilles:
The output of ls -ld /media/data /media/data/Assets ~/bin/SomeJavaApp/data/assets is:

lrwxrwxrwx 1 jjd jjd    92 Aug  9 11:01 /home/jjd/bin/SomeJavaApp/data/assets -> /media/data/Assets/
drwxrwx--- 1 jjd jjd 28672 Aug  6 14:49 /media/data
drwxrwx--- 1 jjd jjd  4096 Aug  8 14:32 /media/data/Assets/

The path I choose in the application is: /home/jjd/bin/SomeJavaApp/data/assets.

share|improve this question
1  
Is your partition mounted rw? and what are the file permissions on the folder assets?. Also, you might have a problem with case-sensitivity here. The error has a capital 'A' while your file path has a small 'a' –  darnir Aug 8 '12 at 13:12
    
According to this website the defaults setting in my fstab means that I mount the partition as read-write. Regarding the case-sensitivity: I only access the files within the folder and therefore do not expect a problem there. How about the umask, should it be 000? –  JJD Aug 8 '12 at 18:33
2  
What path do you provide to the application? Please copy-paste. What is the output of ls -ld /media/data /media/data/Assets ~/bin/myapp/data/assets? –  Gilles Aug 8 '12 at 22:59
    
The name or the resource that appears at the end of the error messages Could not acquire data access ... is merely the alias I enter in the application. Therefore, it is irrelevant to the problem. I removed the string. –  JJD Aug 9 '12 at 9:24
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.