Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Since I upgraded to Ubuntu 12.04, every time I try to open a PDF through Firefox (which I like to do quite often as I read a lot of PDF documents and downloading each then deleting is tiresome) I get the error message:

Could not launch Adobe Reader 9.5.1. Please make sure it exists in PATH variable in the environment. If the problem persists, please reinstall the application.

If I launch Firefox from the terminal the message it gives when attempting to open a PDF is:

(firefox:5989): Gtk-CRITICAL **: IA__gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

(firefox:5989): Gdk-CRITICAL **: IA__gdk_window_set_back_pixmap: assertion `GDK_IS_WINDOW (window)' failed
/usr/bin/acroread: 23: exec: /opt/Adobe/Reader9/Reader/intellinux/bin/acroread: Permission denied

How can I fix this?


I should mention loading a PDF from say the Desktop is fine. I only get error when loading a PDF via the browser.

ADDITIONAL INFO:

ldd /opt/Adobe/Reader9/Reader/intellinux/bin/acroread | grep not 

libBIB.so => not found
libBIBUtils.so => not found
libACE.so => not found
libAGM.so => not found
libCoolType.so => not found
libAXE8SharedExpat.so => not found
libJP2K.so => not found
libAdobeXMP.so => not found
libicuuc.so.36 => not found
libResAccess.so => not found
share|improve this question
    
Output of ls -l /opt/Adobe/Reader9/Reader/intellinux/bin/acroread? –  enzotib Aug 8 '12 at 11:39
    
Output is:-rwxr-xr-x 1 root root 24525572 Mar 28 11:47 /opt/Adobe/Reader9/Reader/intellinux/bin/acroread –  fpghost Aug 8 '12 at 13:03
add comment

2 Answers

The problem is obviously caused by apparmor.

All you need is add a line to /etc/apparmor.d/usr.bin.firefox and reload the rules.

e.g inside the brackets,

  # Allow execution of adobe reader
  /opt/Adobe/Reader9/Reader/intellinux/bin/acroread ixr,

I don't have a 32bit machine, those were not tested.

share|improve this answer
add comment

I would first try fixing permissions, since this looks like a lack of exec-permissions:

sudo chmod 755 /opt/Adobe/Reader9/Reader/intellinux/bin/acroread

This resets the file's permissions to be read and executed by world and group, and read, written, and executed by owner. Now, we'll set the owner to root, for good measure:

sudo chown root: /opt/Adobe/Reader9/Reader/intellinux/bin/acroread

and try again.

share|improve this answer
    
Thanks, I entered both of these, restarted firefox and attempted to open a PDF but still got the same errors as in my OP unfortunately. –  fpghost Aug 8 '12 at 13:06
    
@fpghost Can you try reinstalling acroread? I hope there's no file corruption, especially bad ELF headers... –  hexafraction Aug 8 '12 at 13:07
    
@fpghost Also, can you try executing /opt/Adobe/Reader9/Reader/intellinux/bin/acroread directly? –  hexafraction Aug 8 '12 at 13:09
    
I removed (via SoftwareCentre) acroread then installed it again. I didn't reinstall the firefox plugin itself (as I don't know how-there is a 'disable' option but not remove; also in about:config I can't see it). No luck still. Executing the command you mention gives an error too: "/opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libBIB.so: cannot open shared object file: No such file or directory" –  fpghost Aug 8 '12 at 13:29
    
OK. I'm a little unsure of what to do next. I'm very sorry. –  hexafraction Aug 8 '12 at 13:31
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.