Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to learn some Binux usage and/or programming skills and provide an easy to use browser based picture gallery on my local home network. My idea is to have a server machine, that is the Linux machine, and store all my photos in it at some file structure or database. Then I want to access and manage (CRUD = Create Read Update Delete) them from browser on a tablet machine or mobile phone, connected via WLAN to that server machine.

My need is for a program or technology which would be suitable for the purpose of easily show and manage that content.

  1. Is there ready program running on Linux to do that?

  2. If I have to build this from pieces, which technologies are needed to provide the minimum requirements of CRUD ability?

I remember I have seen some file providers that show links to files at browser, but how ready products/technologies there is available to build such a thing up to your home machine?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Maybe Coppermine Photo Gallery is useful or can serve as a starting point:

Coppermine is a multi-purpose fully-featured and integrated web picture gallery script written in PHP using GD or ImageMagick as image library with a MySQL backend.

If you want to do it yourself, shouldn't be very hard to do with PHP or a web framework using Python, Ruby etc... (Django, Ruby on Rails etc...).

share|improve this answer
    
I am Java oriented, so probably I'll start with something like this tutorial.. or then I'll follow up some of these options.. –  mico Aug 21 '12 at 19:12
add comment

Similar to Coppermine is also Piwigo. It has better usability in terms of using the UI from a tablet device.

More information about Piwigo:

http://www.piwigo.org/

Other requirements:

This worked at least with this combination: Apache 2.2 and php5-gd. Normal php did not work, the gd version is needed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.