Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I check to see if SSH is enabled on Solaris 11? I have tried typing ssh in the terminal, and it came back with a list of options, which none of them made sense to me.

All I want to know is if it is enabled or not.

I am trying to use PuTTY to connect remotely, so I know my IP address that I'm connecting to is correct, but I'm not sure if SSH is enabled on this system.

The reason I tried just typing ssh, was because I normally test to see if gcc is enabled, by typing gcc in the terminal. So I thought it would be the same concept.

Thanks for your help.

share|improve this question
    
My PuTTY wasn't using the correct IP address as I thought it was. I had to change it, as my Network Admin told me to change my IP addresses. –  Kevdog777 Aug 9 '12 at 14:26

1 Answer 1

up vote 5 down vote accepted

svcs ssh will tell you if the ssh service is enabled (online) on your Solaris 11 machine or not.

Note that gcc isn't a service but a command. Running ssh alone and having it displaying possible options means the ssh command (i.e. client) is available.

share|improve this answer
    
Ah Thank you :) –  Kevdog777 Aug 7 '12 at 9:56
    
What about on SPARC, as when I tried svcs ssh, it said svcs: not found. Is it different for SPARC? –  Kevdog777 Aug 10 '12 at 7:58
    
Not at all, svc is part of smf oracle.com/technetwork/server-storage/solaris10/overview/… introduced in Solaris 10 in 2005. Solaris is the same OS regardless of the hardware architecture. I guess your SPARC box is just using Solaris 9 or older. –  jlliagre Aug 10 '12 at 13:19
    
Hi @jlliagre, I did uname -a and this returned: SunOS -I 5.8 Generic_108528-29 sun4u sparc SUNW,Sun-Blade-100. What version of Solaris is that? –  Kevdog777 Aug 10 '12 at 13:34
1  
That's the aging Solaris 8. cat /etc/release shows the precise version/update. –  jlliagre Aug 10 '12 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.