Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In this question I'm asking how to install a compatible driver to a Fedora machine, but, the main problem is a bad resolution.

So, how can I find the best resolution to my monitor and put it to work?

Please answer me with a complete solution or a successfully tutorial.

Some system info is:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

$ cat /etc/issue
Fedora release 17 (Beefy Miracle)
Kernel \r on an \m (\l)

$xandr
 xrandr: Failed to get size of gamma for output default Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024 default connected 1280x1024+0+0 0mm x 0mm 1280x1024 76.0* 1024x768 76.0 800x600 73.0 640x480 73.0

Edit

Looks like the main problema now is this output:

xrandr: Failed to get size of gamma for output default

Everything I try stops at this problem with the gamma.

How can I solve this?

share|improve this question
1  
What makes you think that Xorg did not detect your best resolution? –  Sardathrion Aug 7 '12 at 6:27
    
Because a mac machine on my right side, who has smaller dimensions operates with a bigger resolution. And, because the font isn't good to see and few windows could fit in this huge screen (readable windows). 1280x1024 isn't the resolution to this machine, this is certain. Need to be a bigger one. –  GarouDan Aug 7 '12 at 11:27
    
Have a look at /var/log/Xorg.0.log to see what resolutions Xorg thinks it has. Maybe how to add xrandr resolutions will help as well. –  Sardathrion Aug 7 '12 at 11:42
1  
I tried all options in xrandr --output <Name> --mode 1024x768, where <Name> coulb be VGA,VGA1,VGA-0,LVDS, LVDS1, TMDS, etc. None works. Returns something like xrandr: Failed to get size of gamma for output default warning: output <Name> not found; ignoring. What can I do? –  GarouDan Aug 7 '12 at 12:03
1  
Let me google that for you... –  Sardathrion Aug 7 '12 at 12:07

1 Answer 1

up vote 1 down vote accepted

xrandr -q should give you all the possible resolutions supported by your screen (based on current driver). The one that it's currently using will have an asterisk (*) next to it. If it's at the top of the list, it can't get any higher. It's possible that it's using the wrong aspect ratio (a 16:10 resolution on 16:9 monitor, so things would be a bit stretched). That should be as simple as picking a resolution that matches the aspect ratio of your monitor.

share|improve this answer
    
I'm not currently using Fedora (and looks like I will not do it for soon) so I will embrace this answer because it solves the question. Thx adam. –  GarouDan Apr 16 '13 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.