Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
    Endless timeouts...
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.1.11: bytes=32 time=105ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.11: bytes=32 time<1ms TTL=64
    Request timed out.
    Request timed out.
    Reply from 192.168.1.11: bytes=32 time=105ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=26ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=48ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=71ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=5ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=17ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=39ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=61ms TTL=64
    Reply from 192.168.1.11: bytes=32 time=87ms TTL=64

I'm having a small problem with my debian box (not running any gnome/kde...). I can get the wireless to work, but only if I connect the ethernet cable in for a second or two.

Above is my ping result from my workmachine. I turned off the debian box, started the ping and turned the debian box on. I got a endlessly Request timed out untill i plugged in the ethernet. I've then removed the the ethernet cable (the two time outs in the middle there). Wireless is still up after ethernet is removed and I can putty my way in.

I'm using auto wlan0 but I've also tried allow-hotplug :-( /etc/network/interfaces)

share|improve this question
    
Please post the complete contents of /etc/network/interfaces and anything else network-related that you've configured. Are you also running Network Manager or some such? –  Gilles Aug 6 '12 at 23:38

1 Answer 1

Not knowing more of your /etc/network/interfaces, I can only hope my working example helps you:

/etc/network/interfaces regarding wlan0:

auto wlan0
iface wlan0 inet manual
    wpa-driver wext
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

# known networks
iface default inet dhcp

with /etc/wpa_supplicant/wpa_supplicant.conf a list of wireless networks I occasionally use, e.g.

network={
        ssid="network1"
        key_mgmt=NONE
}
network={
        ssid="this-other-one"
        key_mgmt=WPA-PSK
        psk="wassport"
}

Now if there's a known network to connect to, the ifup mechanism will start a DHCP client process on the interface after connecting successfully.

See /usr/share/doc/ifupdown/examples for more working examples and a lot more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.