Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I've just installed Linux Mint 13, 64 bit (from the CD of "c't kompakt Linux", if this matters), and came across a very unexpected problem, for which I've not found a solution with Google or searching this site: It claims that my LAN cable were not connected. This is surprising because both the live version of Linux Mint (from which I installed it) and the OpenSUSE running on the same computer (on which I'm currently typing this) are connecting quite fine over the very same network cable (which I didn't touch in the mean time).

So what could have gone wrong? And more importantly, what can I do to fix it?


After switching off the computer and disconnecting it from power (due to a thunderstorm), after booting up again it now works. Anyway, if someone has an idea what it might have been (I've not touched the LAN cable at all!), I'd still appreciate to know (in case it happens again).

Update 2:

Although I'm now in Mint 17, it still happens occasionally; rebooting (sometimes twice) helps, therefore I conclude it's not the cable that's at fault (I didn't touch it between the boots). I now also checked (using another computer) that in such a situation my Fritz box (to which the other end of the network cable is plugged) indeed sees the cable as connected, even though Mint doesn't.

Also note that if after boot I don't get the error, I don't get it later either.

I'd like to have a better solution than rebooting the computer.

Update 3:

Here's, as requested in the comments, the output of ifconfig, lspci and lsmod (note: all while the network is working; since the non-working is unpredictable and fortunately not too often, I can't just reproduce it at will).

ifconfig (I omitted the lo entry since I don't think it's relevant):

eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:  Bcast:  Mask:
          inet6 addr: fd00::21b:fcff:fe87:298d/64 Scope:Global
          inet6 addr: fe80::21b:fcff:fe87:298d/64 Scope:Link
          inet6 addr: fd00::f9a9:dfeb:9e90:717b/64 Scope:Global
          RX packets:5339 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4883 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4426282 (4.4 MB)  TX bytes:698006 (698.0 KB)


00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0)
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2)
00:13.3 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3)
00:13.4 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4)
00:13.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)
03:06.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)


snd_hda_codec_hdmi     46207  4 
snd_hda_codec_realtek    61438  1 
snd_hda_intel          52355  7 
snd_hda_codec         192906  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
rfcomm                 69160  0 
bnep                   19624  2 
joydev                 17381  0 
bluetooth             395423  10 bnep,rfcomm
snd_pcm               102099  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
binfmt_misc            17468  1 
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
kvm_amd                59987  0 
kvm                   451511  1 kvm_amd
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69238  24 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
dm_multipath           22873  0 
scsi_dh                14882  1 dm_multipath
serio_raw              13462  0 
edac_core              62291  0 
k8temp                 12978  0 
edac_mce_amd           22617  0 
sp5100_tco             13979  0 
i2c_piix4              22155  0 
soundcore              12680  1 snd
shpchp                 37032  0 
asus_atk0110           18657  0 
parport_pc             32701  1 
ppdev                  17671  0 
lp                     17759  0 
parport                42348  3 lp,ppdev,parport_pc
mac_hid                13205  0 
dm_mirror              22135  0 
dm_region_hash         20862  1 dm_mirror
dm_log                 18411  2 dm_region_hash,dm_mirror
hid_generic            12548  0 
usbhid                 52616  0 
hid                   106148  2 hid_generic,usbhid
pata_acpi              13038  0 
firewire_ohci          40409  0 
psmouse               102222  0 
firewire_core          68769  1 firewire_ohci
crc_itu_t              12707  1 firewire_core
pata_atiixp            13271  0 
nouveau              1097199  3 
floppy                 69370  0 
mxm_wmi                13021  1 nouveau
r8169                  67581  0 
wmi                    19177  2 mxm_wmi,nouveau
video                  19476  1 nouveau
mii                    13934  1 r8169
i2c_algo_bit           13413  1 nouveau
ttm                    85115  1 nouveau
drm_kms_helper         52758  1 nouveau
drm                   302817  5 ttm,drm_kms_helper,nouveau
ahci                   25819  4 
libahci                32168  1 ahci

Update 4:

It has happened again. Since dmesg had over 800 lines, I've run egrep -n '(r8169|eth0)' on it (r8169 is the kernel module identified by Ned64 in the comments as responsible for the ethernet controller); I hope that catches everything relevant. Here's the result:

629:[    1.431823] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
630:[    1.431840] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
632:[    1.432178] r8169 0000:02:00.0: irq 42 for MSI/MSI-X
633:[    1.432341] r8169 0000:02:00.0 eth0: RTL8168b/8111b at 0xffffc90000368000, 00:1b:fc:87:29:8d, XID 18000000 IRQ 42
634:[    1.432343] r8169 0000:02:00.0 eth0: jumbo features [frames: 4080 bytes, tx checksumming: ko]
791:[    5.214715] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
862:[    6.773423] r8169 0000:02:00.0 eth0: link down
863:[    6.773438] r8169 0000:02:00.0 eth0: link down
864:[    6.773963] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
865:[    6.774513] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Reloading the kernel module as suggested by Ned64 fixed the problem without a reboot, so that's a workable workaround, but of course I'd still prefer a solution that solves the problem without manual intervention.

share|improve this question
If it is a driver problem, you could try removing and re-inserting the kernel module which drives your ethernet chip, so you don't need to reboot. Anyway: To find out more, please post the output of (run as root) ifconfig (remove the MAC address if you worry about privacy), lspci | grep -i eth and lsmod. Also, run dmesg WHILE the error is active and post the output. – Ned64 Aug 30 at 8:00
@Ned64: I've added the output of ifconfig, lspci and lsmod. Since I can't predict when the error will occur the next time, the dmesg will have to wait. – celtschk Aug 30 at 8:18
Your ethernet device is an "RTL8111/8168/8411" and uses the r8169 kernel module. This you could try re-loading after the dmesg to see if you can fix it. Let's wait for your output... – Ned64 Aug 30 at 8:25
Thanks for that information. I've saved it in a file so I can access it when the error happens next time. – celtschk Aug 30 at 8:53
@Ned64: It happened again, I now added (hopefully all of) the relevant dmesg output. Reloading the kernel module indeed helped, so now I have a better solution than rebooting, so you already helped me, thank you for that. But of course, ideally I'd prefer it just to work. – celtschk Sep 5 at 6:18

1 Answer 1

After getting the information from your ifconfig, lsmod and lspci | grep -i eth, as well as dmesg during the error, it is clear that you have a problem with the r8169 kernel module for your Realtek Ethernet adapter.

As a short-term fix to re-start your Ethernet card and re-connect to the network, use rmmod r8169 and modprobe r8169 (as root) when the error occurs.

As a longer-term solution you might switch the driver for your Ethernet adapter. Some others have used the r8168 after using the r8169 before. This is one report of someone who has done so:

Of course, it is potentially harmful to download and run scripts by someone you do not know. You could get the newest version of the driver directly from Realtek here:

When you install your own kernel module to replace an existing one, do not forget to blacklist the old module so that it isn't used automatically, like so:

echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf

(see whether that works on your system), and remember that you probably need to re-build the new kernel module whenever you upgrade the linux kernel.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.