Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I have Tomcat and Apache installed in CentOS 5. They're integrated with a help of

They both display the same in and

But I'd like to make the context cms displayed only when I access with address below.

How could the context "" turn into "" ?

share|improve this question

2 Answers 2

Do you have an apache config for this site? If so, please post it so we can get a better idea of how you have your site set up.

Here is one way to do it (with mod_proxy and mod_rewrite):


<VirtualHost *>
        RewriteEngine On
        ProxyPass /
        ProxyPassReverse /

Proxy setting in Tomcat $TOMCAT_HOME/conf/server.xml

<Connector port="8080" protocol="HTTP/1.1"
               redirectPort="8443" proxyPort="80" />

Restart apache and visit to see if its working for you.

share|improve this answer

In the web server config of add the following line:

Redirect /cms

For more information , refer to apache documentation at

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.