Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Ubuntu, and I'm having trouble reading text in MC and Aptitude because of the color scheme. Is there any way to change it?

share|improve this question
add comment

2 Answers

Maybe a quick fix: mc -b forces no-color mode ;)

You can write your own skins for mc, which include a color scheme. They live in ~/.mc/skins and are selected by mc -S skinname. This article talks a bit about it and has an example available for download at the end.

But maybe the deeper trouble is that your term background is "not the expected color", so another way would be to change how your term displays the 16 "standard colors". (For example, this would make all formerly-green items purple, if that's better for you from a contrast standpoint.) How this is done depends on your terminal emulator, for example XFCE's Terminal has it in its preferences dialog, for xterm you probably need to edit a configuration file etc.

share|improve this answer
add comment

From the changelog:

Version 4.8.0-pre1

WARNING: Configuration files was moved from your $HOME/.mc directory into XDG_CONFIG_* directories to respect FDO standard (http://standards.freedesktop.org/basedir-spec/basedir-spec-0.7.html)

mcedit .config/mc/ini
search for skin with F7
skin=modarin256 is really nice for example :) Look into /usr/share/mc/skins/ to see the different themes.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.