Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Simple problem, not so simple solution as it seems to me. Whenever I try to start viewing my webcam, I get the following error:

libv4l2: error turning on stream: Input/output error

be it cheese, camorama or vlc. Except in some special cases which I can not reproduce, where it will just work. I've tried to compile it as a kernel module or right into the kernel. In both cases, it randomly works sometimes but not reliably.

VLC actually shares some more what's going wrong.

[0x97a63f8] v4l2 demux error: VIDIOC_STREAMON failed
libv4l2: error setting pixformat: Device or resource busy (repeats 10 times)
[0xb7319dc8] v4l2 access error: cannot set input 0: Device or resource busy
[0xb7319dc8] v4l2 access error: cannot set input 0: Device or resource busy
[0x9806cd0] main input error: open of `v4l2:///dev/video0' failed

I cannot quite tell what camera model it is, as it is built into the laptop and the specification sheet won't give more information either: http://www.hp.com/hpinfo/newsroom/press_kits/2009/Mobility2009/Datasheet-Datasheet.HPEliteBook6930p.pdf

lsusb gives me:

Bus 005 Device 002: ID 04f2:b053 Chicony Electronics Co., Ltd 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2 ?
  bDeviceProtocol         1 Interface Association
      bMaxPacketSize0        64
      idVendor           0x04f2 Chicony Electronics Co., Ltd
  idProduct          0xb053 
  bcdDevice           32.18
      iManufacturer           2 Chicony Electronics Co., Ltd.
  iProduct                1 CKA7216
  iSerial                 3 SN0001
  bNumConfigurations      1
... much more stuff whose relevance I cannot assess ...


Some pages suggest to preload a compatibility library, namely /usr/lib/libv4l/v4l1compat.so, but no difference:

$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so  cheese
libv4l2: error turning on stream: Input/output error

I'll be happy about every suggestion to allow me narrowing down the problem's source and will investigate any further if somebody comes up with an idea where to look.

share|improve this question
Does your user (one which is running vlc and others) have appropriate permissions to access /dev/video0? –  webKnjaZ Dec 13 '13 at 22:32
I actually switched systems in the meantime, so I'm not experiencing this anymore. But I remember that I made sure I had access to /dev/video0. Also, since it randomly worked, I'm assuming it wasn't a permissions problem. –  jonny Dec 14 '13 at 0:50
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.