Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I had errors with apt-get update && apt-get dist-upgrade, from mono mono, so I tried this instead:

sudo apt-get install --reinstall banshee banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore giver libappindicator0.1-cil libart2.0-cil libavahi1.0-cil libgconf2.0-cil libgdata1.7-cil libgkeyfile1.0-cil libglade2.0-cil libglib2.0-cil libgmime2.4-cil libgnome-vfs2.0-cil libgnome2.24-cil libgtk-sharp-beans-cil libgtk2.0-cil libgudev1.0-cil liblaunchpad-integration1.0-cil libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo2.0-cil libmono-corlib1.0-cil libmono-corlib2.0-cil libmono-data-tds1.0-cil libmono-data-tds2.0-cil libmono-i18n-west1.0-cil libmono-i18n-west2.0-cil libmono-management2.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil libmono-security1.0-cil libmono-security2.0-cil libmono-sharpzip0.84-cil libmono-sharpzip2.84-cil libmono-sqlite2.0-cil libmono-system-data-linq2.0-cil libmono-system-data1.0-cil libmono-system-data2.0-cil libmono-system-messaging2.0-cil libmono-system-web1.0-cil libmono-system-web2.0-cil libmono-system1.0-cil libmono-system2.0-cil libmono-wcf3.0-cil libmono-zeroconf1.0-cil libmono1.0-cil libmono2.0-cil libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnotify0.4-cil libtaglib2.0-cil libubuntuone1.0-cil mint-meta-gnome-dvd mono-2.0-gac mono-csharp-shell mono-gac mono-gmcs mono-runtime tomboy > ./errors2.txt

http://pastebin.com/YJszy4q4

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libcommons-pool-java libtomcat6-java libcommons-dbcp-java
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 60 reinstalled, 0 to remove and 0 not upgraded.
56 not fully installed or removed.
Need to get 0 B/1,846 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 334292 files and directories currently installed.)
Preparing to replace libmono-posix2.0-cil 2.6.7-5ubuntu3.1 (using .../libmono-posix2.0-cil_2.6.7-5ubuntu3.1_all.deb) ...
Unpacking replacement libmono-posix2.0-cil ...
Preparing to replace libmono-security2.0-cil 2.6.7-5ubuntu3.1 (using .../libmono-security2.0-cil_2.6.7-5ubuntu3.1_all.deb) ...
Unpacking replacement libmono-security2.0-cil ...
Preparing to replace libmono-system2.0-cil 2.6.7-5ubuntu3.1 (using .../libmono-system2.0-cil_2.6.7-5ubuntu3.1_all.deb) ...
Unpacking replacement libmono-system2.0-cil ...
Preparing to replace mono-2.0-gac 2.6.7-5ubuntu3.1 (using .../mono-2.0-gac_2.6.7-5ubuntu3.1_all.deb) ...
Unpacking replacement mono-2.0-gac ...
Processing triggers for man-db ...
Setting up libmono-posix2.0-cil (2.6.7-5ubuntu3.1) ...
Setting up libmono-system2.0-cil (2.6.7-5ubuntu3.1) ...
Setting up libmono-security2.0-cil (2.6.7-5ubuntu3.1) ...
Setting up mono-2.0-gac (2.6.7-5ubuntu3.1) ...
Setting up mono-gac (2.6.7-5ubuntu3.1) ...
* Installing 3 assemblies from libappindicator0.1-cil into Mono
E: installing Assembly /usr/lib/cli/appindicator-sharp-0.1/appindicator-sharp.dll failed
E: Installation of libappindicator0.1-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 6 assemblies from libart2.0-cil into Mono
E: installing Assembly /usr/lib/cli/art-sharp-2.0/art-sharp.dll failed
E: Installation of libart2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libavahi1.0-cil into Mono
E: installing Assembly /usr/lib/cli/avahi-sharp-1.0/avahi-sharp.dll failed
E: Installation of libavahi1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 6 assemblies from libgconf2.0-cil into Mono
E: installing Assembly /usr/lib/cli/gconf-sharp-2.0/gconf-sharp.dll failed
E: Installation of libgconf2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 14 assemblies from libgdata1.7-cil into Mono
E: installing Assembly /usr/lib/cli/Google.GData.AccessControl-1.7/Google.GData.AccessControl.dll failed
E: Installation of libgdata1.7-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libgkeyfile1.0-cil into Mono
E: installing Assembly /usr/lib/cli/gkeyfile-sharp-1.0/gkeyfile-sharp.dll failed
E: Installation of libgkeyfile1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libglade2.0-cil into Mono
E: installing Assembly /usr/lib/cli/glade-sharp-2.0/glade-sharp.dll failed
E: Installation of libglade2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libglib2.0-cil into Mono
E: installing Assembly /usr/lib/cli/glib-sharp-2.0/glib-sharp.dll failed
E: Installation of libglib2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libgmime2.4-cil into Mono
E: installing Assembly /usr/lib/cli/gmime-sharp-2.4/gmime-sharp.dll failed
E: Installation of libgmime2.4-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 2 assemblies from libgnome2.24-cil into Mono
E: installing Assembly /usr/lib/cli/gnome-sharp-2.24/gnome-sharp.dll failed
E: Installation of libgnome2.24-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 6 assemblies from libgnome-vfs2.0-cil into Mono
E: installing Assembly /usr/lib/cli/gnome-vfs-sharp-2.0/gnome-vfs-sharp.dll failed
E: Installation of libgnome-vfs2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 5 assemblies from libgtk2.0-cil into Mono
E: installing Assembly /usr/lib/cli/gtk-sharp-2.0/gtk-sharp.dll failed
E: Installation of libgtk2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libgudev1.0-cil into Mono
E: installing Assembly /usr/lib/cli/gudev-sharp-1.0/gudev-sharp.dll failed
E: Installation of libgudev1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from liblaunchpad-integration1.0-cil into Mono
E: installing Assembly /usr/lib/cli/launchpad-integration-sharp-1/launchpad-integration-sharp.dll failed
E: Installation of liblaunchpad-integration1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 7 assemblies from libmono-addins0.2-cil into Mono
E: installing Assembly /usr/lib/cli/Mono.Addins-0.2/Mono.Addins.dll failed
E: Installation of libmono-addins0.2-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 3 assemblies from libmono-addins-gui0.2-cil into Mono
E: installing Assembly /usr/lib/cli/Mono.Addins.Gui-0.2/Mono.Addins.Gui.dll failed
E: Installation of libmono-addins-gui0.2-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 5 assemblies from libmono-zeroconf1.0-cil into Mono
E: installing Assembly /usr/lib/cli/Mono.Zeroconf-1.0/Mono.Zeroconf.dll failed
E: Installation of libmono-zeroconf1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libndesk-dbus1.0-cil into Mono
E: installing Assembly /usr/lib/cli/NDesk.DBus-1.0/NDesk.DBus.dll failed
E: Installation of libndesk-dbus1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libndesk-dbus-glib1.0-cil into Mono
E: installing Assembly /usr/lib/cli/NDesk.DBus.GLib-1.0/NDesk.DBus.GLib.dll failed
E: Installation of libndesk-dbus-glib1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libnotify0.4-cil into Mono
E: installing Assembly /usr/lib/cli/notify-sharp-0.4/notify-sharp.dll failed
E: Installation of libnotify0.4-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 2 assemblies from libtaglib2.0-cil into Mono
E: installing Assembly /usr/lib/cli/taglib-sharp-2.0/taglib-sharp.dll failed
E: Installation of libtaglib2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from libubuntuone1.0-cil into Mono
E: installing Assembly /usr/lib/cli/ubuntuone-sharp-1.0/ubuntuone-sharp.dll failed
E: Installation of libubuntuone1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing mono-gac (--configure):
 subprocess installed post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of mono-runtime:
 mono-runtime depends on mono-gac (= 2.6.7-5ubuntu3.1); however:
  Package mono-gac is not configured yet.
dpkg: error processing mono-runtime (--configure):
 dependency problems - leaving unconfigured
(…)
dpkg: too many errors, stopping
Errors were encountered while processing:
 mono-gac
 mono-runtime
 libmono-corlib2.0-cil
(…)

I have Linux Mint 11 x64.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.