Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Windows XP/Debian Squeeze (XFCE desktop) dual-boot set up on a Dell Latitude laptop. The Windows XP portion boots fine. However, sometimes the Debian portion does not boot. If it doesn't boot, and I do a hard reboot, it will boot the second time. However, sometimes Debian will boot the first time.

How can I diagnose this problem?

All help appreciated!

[EDIT] I should mention that the improper boot manifests itself as a failure to reach the login screen. I see the standard Debian wallpaper with the stars and so on, but it doesn't display the login box.

share|improve this question
1  
In the Grub menu (where you choose between Linux and Windows), edit the Linux command to remove the words quiet and splash from the line that begins with linux /vmlinuz. Where does the boot hang? What are the last few messages on the screen (since you won't be able to copy-paste, try to take a legible picture)? –  Gilles Jul 31 '12 at 22:22
    
Ok, I'll give that a try. It might be a little while before I can do that, though. –  Adrian Keister Jul 31 '12 at 22:33
    
I'm using the Windows boot loader, not Grub, to choose into which OS I wish to boot. Can I edit the boot.ini file in Windows somehow to achieve what you're suggesting? –  Adrian Keister Aug 23 '12 at 19:57
    
Regardless of what you use to choose your OS, there's a bootloader that loads Linux. What is it? Grub? Lilo? Syslinux? Something else? –  Gilles Aug 23 '12 at 19:58
    
I'm using Grub for Linux. –  Adrian Keister Aug 23 '12 at 20:10
show 1 more comment

2 Answers

Is this by any chance a Latitude C600 or a similar model (own one myself, have similar problems)?

AFAIK this is the graphics driver that is causing the problem. Can you boot to console in failsafe (recovery mode)? Check and regenerate your xorg.conf file, make sure all the settings are right.

share|improve this answer
    
It's a Latitude E5400. The graphics card, according to the dxdiag routine in WinXP, is a Mobile Intel(R) 4 Series Express Chipset Family card. As for booting to cli, would I do #update-rc.d -f gdm remove? Remember I have XFCE, although I did not do a Gnome-free Debian install. Sorry, newbie here. How do I regenerate xorg.conf? Thanks for your help! –  Adrian Keister Jul 31 '12 at 2:33
1  
You could do that with update-rc.d, if it doesn't work for you just remove it (aptitude remove gdm). Regenerate xorg.conf with dpkg-reconfigure xserver-xorg. Also, have you tried booting to recovery mode (failsafe) like I suggested in the answer? Try that before you do anything else. –  Secko Aug 1 '12 at 11:16
add comment

This is probably a buggy driver, now the problem is to find out which. The first thing to investigate is to look at the logs: /var/log/kern.log and /var/log/Xorg.0.log. Note that that latter file is restared each time you boot; if you've rebooted into X since the failure, the previous log will be in /var/log/Xorg.0.log.old.

The OS may gave crashed before it could write the logs, but there is probably a message on the console. To make this message appear, you need to deactivate the boot-time splash screen. With Grub 2, edit /etc/default/grub and change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to just GRUB_CMDLINE_LINUX_DEFAULT="". Hopefully, the next time the bug prevents your system from booting normally, the last few lines on the screen will tell you what's wrong.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.