Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using a Fedora 13 OS and i see that in the network connections the WiFi thing has been disabled. Generally when there is a WiFi connection around it would show in the Wireless networks option, but it is not showing for me. What to do, in order to keep the WiFi mode always active.

ADDED

I have tried the following

iwlist wlan0 power

It says the mode is off.

ifconfig wlan0 gives me the following output:

wlan0 Link encap:Ethernet HWaddr 00:19:7D3:0C:FD
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

iwconfig has the following:

wlan0 IEEE 802.11bg Mode:Managed Access Point: Not-Associated
Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

share|improve this question
    
You got your physical laptop wifi button switched on? You have the right firmware installed? (optional) You got a screenshot? –  Tshepang Nov 30 '10 at 1:56
    
@chrandu1, please clarify "wifi thing". And like Tshepang mentioned, ensure that your wifi switch is set to 'on'. –  Stefan Nov 30 '10 at 7:39
    
@Stefan: i have my wifi button on, but still when i have wired network it gets connected, but when there is a wifi network it doesnt show the connections at all. How do i search for a wifi connection if i know that i am in an area with wifi conectivity –  Chandrasekhar Dec 1 '10 at 1:21
    
running this iwlist wlan0 scanning as root should show you a list of found devices... also see man iwlist and iwlist --help –  Stefan Dec 1 '10 at 8:10
    
@Stefan: it says interface doesnt support scanning network is down –  Chandrasekhar Dec 1 '10 at 8:16

1 Answer 1

Why do you bother with weird iwconfig commands. Have you used "nm-applet" command? This is a GNOME Network Management applet. I tried to manage wireless connections with iwconfig on my Fedora's laptop but gave up. nm-applet does all the job you need. Just select auto-connect option for your wireless connection and it will connect you each time wifi is up.

I use this applet in PekWM window manager with bmpanel application. This is because Pekwm does not have panel itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.