Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to burn a DVD using GParted (not a DVD of GParted).

I see that GParted uses a Debian distro (Wheezy). I am trying to install dvd+rw-tools:

sudo apt-get install dvd+rw-tools

Package dvd+rw-tools is not availble, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only availble from another source

Fine. Then I try to add another repository:

sudo apt-add repository ppa:ferramroberto/extra

sudo: add-apt-repository: command not found

Then, I try to install python-software-properties:

sudo apt-get install python-software-properties

And get

Unable to locate package python-software-properties

How can I make this work?

share|improve this question
    
have you performed an apt-get upadte after adding the repository? –  Momo Aug 3 '12 at 10:28
    
@Momo - I don't remember anymore. I eventually found the OS disk, so I didn't need to solve this problem. For those who need it, this might help: gparted-forum.surf4.info/viewtopic.php?pid=29773#p29773 –  ripper234 Aug 4 '12 at 6:45
add comment

1 Answer

First of all don't use ppa repos for this. The dvd+rw-tools package is available in the main debian repositories. Edit /etc/apt/sources.list and add this line:

deb ftp://ftp.debian.org/debian/ wheezy main contrib non-free

The update the list of available packages:

$ sudo apt-get update

Now you should be able to install dvd+rw-tools:

$ sudo apt-get install dvd+rw-tools

You probably don't even need to do that. If you follow the instructions given in the link you provide in your question and try to install wodim, it should also install all its dependencies. If the correct repository is present everything should work.

share|improve this answer
    
You need an apt-get update in there. I'm going to go ahead and edit it in for you, feel free to revert if you disagree. –  derobert Feb 22 '13 at 17:30
    
@derobert, I do indeed, thanks! –  terdon Feb 22 '13 at 17:38
    
I think you need to refer to the wheezy repo (see the OP) –  Joseph R. May 24 '13 at 11:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.