Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So I finally decided to move from Windows to Linux. But before that I have wanted to try Fedora distribution from LiveCD. So I downloaded Fedora 17 .iso file, unpacked it and then burned on my CD. I rebooted the computer and saw message saying "Select proper boot device" (and yes, I change settings right in BIOS). So my next step was creating LiveUSB with help of this creator. I still got the same message, even on my friends computer.

File structure of the LiveUSB (CD) looks like this

  • boot
  • EFI
  • LiveOS
  • syslinux
  • GPL (file)

Can anybody advice what could possibly be the problem?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

Maybe .iso file isn't good or maybe you made some mistake before burning it. Try not to unpack .iso file. Just download CDBurnerXP (it is free) or something like that, choose option "Burn ISO image" and program will do everything for you (unpack and burn). Give it a try ;)

share|improve this answer
    
Well, this could be the reason for the CD but I also tried to boot it from the USB drive and it didn't work. I doubt this would help (because I used software directly from Fedora to create the LiveUSB) –  Petr Mensik Jul 28 '12 at 9:03
    
Thank you, it was really it, so I am sorry for being a stubborn:) –  Petr Mensik Jul 28 '12 at 20:51
    
No problem, enjoy in good distro ;) –  cyb3r Jul 30 '12 at 8:24
add comment

Two ideas:

  1. The iso file might be corrupt/broken (also, like cyb3er suggested, you should not unpack the file). Did you verify the integrity of the file via MD5/SHA checksum? The Fedora Project site gives instructions on how to do this: https://fedoraproject.org/en/verify
  2. Could you check with a partition editor like GParted whether the partition with the contents of the Live CD/USB has the boot flag set?
share|improve this answer
add comment

On top of what others have suggested above:

Maybe you got a 64bit version for a 32 bit machine or another version incompatible with your hardware. Have you checked this>

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.