Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an uncommon setup. I have Ubuntu installed on one, and a backup from a direct copy of an older Arch Linux install on the second. By direct copy, I mean I tar'd the contents of an entire partition initially, and now I've extracted those contents to another partition. So:

1 - Ubuntu, with GRUB2

2 - Arch from a backup

Ubuntu runs and boots fine. After extracting Arch to a partition, I changed fstab to reflect its new partition. But now I'm stuck trying to get Arch to boot. I tried running update-grub in Ubuntu but it doesn't pick up the Arch install. So how can I get this to work?

share|improve this question
    
Grub doesn't use fstab –  matzahboy Aug 14 '12 at 5:32

4 Answers 4

I had a similar problem after installing Fedora 17. Ubuntu would not pick it up. After finding no answers on the net, I wondered if it was because grub couldn't 'see' the Fedora install. So I mounted the Fedora / partition in Ubuntu and ran update-grub and it found the Fedora install and added it to the boot menu. I use the same technique with Archlinux

share|improve this answer

Have you tried following the ArchWiki article on Grub2? You probably want to install the package called os-prober on your system before running grub-mkconfig. This will create the correct grub.cfg file for your system.

Let me know if you need more help.

share|improve this answer

Currently you are using grub from your Ubuntu installation, if you want to boot Arch from it, you have to add a custom entry configuring your Ubuntu so each time a package executes update-grub, your new entry is not removed.

The new entry should look quite similar to what you have already for booting ubuntu but referencing Arch's partitions and using Arch's kernel parameters (you could probably use Arch's wiki page on grub2).

For more information, take a look here: https://help.ubuntu.com/community/Grub2/CustomMenus

share|improve this answer

Twoxmeles' answer worked for me. The update-grub command on my machine wouldn't see ARCH with the partition unmounted.

After mounting the ARCH partition, no problem. GRUB picked it up and updated my boot menu

share|improve this answer
    
Hi and Welcome to Unix & Linux! Please read the How to Answer a Question Guide. This site is a Q&A site not a forum. –  slm Apr 8 '13 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.