Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am having difficulty starting up the Xorg server within my Gentoo installation. I set it up via The X Server Configuration HOWTO. When I get to the part where I startx, the screen flickers a bit, and then it drops me back into the terminal with the following message:

[some stuff here]
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
FATAL: COuld not load /lib/modules/2.6.35-gentoo-r12/modules.dep: No such file or directory

Two things that are weird to me - I am not using vesa or fbdev drivers. I am using intel and evdev in my /etc/make.conf. Secondly, I don't use modules in my kernel. I specifically remove them. This hasn't caused a problem before. I'm not really sure what is going on. Any help would be much appreciated.

share|improve this question
    
Have you installed the correct drivers for your card? Im no xorg expert but I would think that if xorg was trying to load vesa, it did not find the intel drivers... –  Stefan Nov 27 '10 at 7:42
    
@Stefan - I believe I did. I have an integrated Intel chip (on an old laptop) and it's the same driver that is used during the setup process. (And, video up to this point seems to be working...just not video inside Xorg.) –  JasCav Nov 27 '10 at 7:49
1  
The "vesa" and "fbdev" modules listed are Xorg server modules, not kernel modules. They are .so files found in /usr/lib/xorg/modules/drivers and are the fallbacks Xorg automatically tries if the specific driver module for your screen can't be loaded. –  alanc Nov 27 '10 at 15:36

2 Answers 2

I am using intel and evdev in my /etc/make.conf

That means that xorg will be compiled with intel and evdev support :)
Xorg doesn't read your make.conf, it tries to guess your hardware if there's no xorg.conf and it looks like it can't guess your hardware.

emerge sys-apps/lshw sys-apps/pciutils
and look for UNCLAIMED and DISABLED devices in lshw output. lspci can also be usefull.

Try running:

X -configure

Then customize (put correct driver in appropriate place in) it's output ~/xorg.conf.new and use it as your xorg.conf

I generally don't use modular kernel

That doesn't matter in this case, but that means that you can't load module with parameters, which sometimes useful.

share|improve this answer

FATAL: Could not load /lib/modules/2.6.35-gentoo-r12/modules.dep: No such file or directory

Make sure you ran make modules_install for your kernel.

share|improve this answer
    
Yeah, I considered that. I generally don't use a modular kernel - I build everything into the kernel. Does it have to be modular for this to work? –  JasCav Nov 27 '10 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.