Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a new FreeBSD 9.0-RELEASE with a ports tree generated via portsnap and none of the ports perform make config.

To some degree it is behaving as though BATCH=yes was set. However, that variable does not appear in /etc/make.conf (which is actually blank); nor is it set in the environment. make -V BATCH returns blank. make config pulls up the dialog screens and then happily writes options out to /var/db/ports/[whatever]/options; but simply running make (or using portmaster) skips the config process and writes nothing out to /var/db/ports.

What on earth is happening?

share|improve this question
During install did you populate the ports tree? If not you can rerun the sysinstall or download the tarball and extract it. See freebsd.org/ports/installing.html – Tim Jul 19 '12 at 18:19
Nah. We always skip that step and run 'portsnap fetch extract' instead. By the time we get our hands on an ISO, the ports tree on the disc is already old. – ericx Jul 19 '12 at 18:39
go to a port dir and run make config. Does it come up with a configuration window? – EhevuTov Aug 15 '12 at 0:28
This can be other files besides your environment, page through /etc/make.conf or post it anywhere. – kworr Sep 17 '12 at 12:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.