Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed TexLive 2012 via the official site and want to install epydoc which depends on an older version. However, when I try to install epydoc which depends on texlive, I get the below error.

How can I fix this?

; sudo yum install epydoc     
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, remove-
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, remove-
              : with-leaves
Loading mirror speeds from cached hostfile
 * fedora: ftp.tudelft.nl
 * livna: rpm.livna.org
 * rpmfusion-free: ftp.upjs.sk
 * rpmfusion-free-updates: ftp.upjs.sk
 * rpmfusion-nonfree: ftp.upjs.sk
 * rpmfusion-nonfree-updates: ftp.upjs.sk
 * updates: ftp.tudelft.nl
Resolving Dependencies
--> Running transaction check
---> Package epydoc.noarch 0:3.0.1-9.fc15 will be installed
--> Processing Dependency: texlive-latex for package: epydoc-3.0.1-9.fc15.noarch
Package texlive-latex-2007-66.fc16.x86_64 is obsoleted by 1:tex-latex-svn23639-1
.noarch which is already installed
--> Processing Dependency: texlive-dvips for package: epydoc-3.0.1-9.fc15.noarch
Package texlive-dvips-2007-66.fc16.x86_64 is obsoleted by 1:tex-dvips-svn26765-1
.noarch which is already installed
--> Finished Dependency Resolution
Error: Package: epydoc-3.0.1-9.fc15.noarch (fedora)
           Requires: texlive-dvips
           Available: texlive-dvips-2007-65.fc16.x86_64 (fedora)
               texlive-dvips = 2007-65.fc16
           Available: texlive-dvips-2007-66.fc16.x86_64 (updates)
               texlive-dvips = 2007-66.fc16
Error: Package: epydoc-3.0.1-9.fc15.noarch (fedora)
           Requires: texlive-latex
           Available: texlive-latex-2007-65.fc16.x86_64 (fedora)
               texlive-latex = 2007-65.fc16
           Available: texlive-latex-2007-66.fc16.x86_64 (updates)
               texlive-latex = 2007-66.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted
  1. You could try using --skip-broken to work around the problem
  2. Contact the TEX-Developers and report this as bug
  3. If you really want to, you can try yum downgrade

Update: Since yum --skip-broken does not work here:

yumdonwloader epydoc-3.0.1-9.fc15.noarch
rpm -i --nodeps epydoc-3.0.1-9.fc15.noarch.rpm

Should work.

share|improve this answer
    
--skip-broken does not install epydoc which kinda defeats the point of installing it. –  Sardathrion Jul 19 '12 at 12:41
    
By TEX-Developers who do you mean? Do you mean the package maintainers for latex live or epydoc or both? –  Sardathrion Jul 19 '12 at 12:42
1  
@Sardathrion this seems to be a epydoc-problem. It should be sufficient if the newer version of tex-dvips is installed. This has to be coded into the requires-section of the epydoc-rpm. –  Nils Jul 19 '12 at 12:54
    
@Sardathrion Updated my answer so you can circumvent the dependencies. –  Nils Jul 19 '12 at 13:03
    
That worked. Thank you. –  Sardathrion Jul 19 '12 at 13:46
add comment

You should either use the packages for Fedora, or use the packages for TeXlibe 2012 from Jindrich Novy's repo. Don't mix, they don't work well together (jnovy's uses other directories, they won't find each other at all).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.