Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

raspberry-pi-7 1.jpg

Just got my Raspberry Pi in the mail and I've started playing around with it. After getting LXDE up and working working in desktop mode (i.e. monitor and keyboard plugged in) I decided I wanted to connect to it remotely.

I know I can use a VNC/RDP client but maybe for now just connecting with XForwarding and launching lxsession would be fine. To describe my environment, I'm using OS X I had previously installed XQuartz.app to replace the native X11 app (because it boasted more features and benefits for using X applications).

The first time I connected as root via ssh to the remote machine and launched lxsession it gave me the behavior that I am seeing to have again - I kept my Mac OS X desktop background and it simply overlaid the LDE menu at the bottom of the screen - sort of a transparent desktop:

Screen shot 2012-07-18 at  copy.png

However now when most of the time when I do these steps again it not have a transparent desktop - it will in fact show the LXDE background:

Picture copy 3.png

Is there an option I'm missing to be able to be able to achieve the "transparency" or "integrated" version?

I looked in the LXDE Desktop Preferences and didn't see an option to disable it:

Picture 1.png

I have tried setting the desktop image to a transparent gif file which will remove the picture, but then I didn't see any way to remove the desktop background color - because after I select the transparent file I am just getting a solid color.

How can I achieve the "transparency" or "integrated" version of LXDE via X forwarding from OS X?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I'm not the expert in X11 and even Linux, but I heard that OS X implementation of Xorg Server doesn't support some required extensions for visually rich UI. Or may be transparency (and other effects) in Linux can only be achieved with composition manager (such as xcompmgr, Compiz, etc.) on client side, so they can not transfer them over network based X11 protocol.

I suggest you to try also X2go and NoMachine 3.4 / 4.

share|improve this answer
    
looks good. not sure when i can try this so i'm going to mark it as correct until I find it incorrect. thanks! –  cwd Dec 7 '12 at 16:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.