Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
 273     <keybind key="W-Return">
 274       <action name="Execute">
 275         <command>lxterminal</command>
 276       </action>
 277     </keybind>
 278     <keybind key="W-Up">
 279       <action name="ToggleMaximizeFull"/>
 280     </keybind>
 281     <keybind key="W-Left">
 282       <action name="MoveToEdgeWest"/>
 283     </keybind>
 284     <keybind key="W-Right">
 285       <action name="MoveToEdgeEast"/>
 286     </keybind>

I added these lines in between the default last </keybind> and </keyboard> in my ~/.config/openbox/rc.xml file (the line numbers are from vim). However, neither restarting X nor issuing an openbox --reconfigure applies these settings.

What am I doing wrong? I'm using Arch with all the default LXDE packages.

share|improve this question
1  
Are you sure that you have the file in the proper path? –  pedrosaurio Jul 19 '12 at 17:01
    
Did you receive any error dialog ? If so, the configure xml file is malformed –  warl0ck Aug 19 '12 at 0:35
1  
Pastebin and link to the complete rc.xml - a fragment is not that useful... –  jasonwryan Aug 19 '12 at 1:41

4 Answers 4

Make sure you use the path in your home directory

.config/openbox/rc.xml

not

~./config/openbox/rc.xml

share|improve this answer
    
That is where it is; I made a typo in the OP. –  Randall Ma Jul 19 '12 at 21:39
    
Does it work now? If yes, you can mark the answer as the correct one. –  pedrosaurio Jul 23 '12 at 10:57
    
Nope. Nevertheless, I've gone ahead and switched to xfwm4, but if this question accumulates more answers I'll go and test them. Thanks for your help. –  Randall Ma Jul 23 '12 at 17:15

On LXDE ~/.config/openbox/lxde-rc.xml config is used instead.

To check how openbox was started you can do:

$ ps ax | grep openbox
 2109 ?        S      0:29 openbox --config-file /home/marcin/.config/openbox/lxde-rc.xml
share|improve this answer

i've been struggling with the same problem for an hour now and the answer i'm afraid is quite silly and straightforward. You should locate you keybinds within the keyboard block inside the rc.xml other wise they won't work.

I hope i answered your question :).

share|improve this answer

There is also

$ openbox --restart

Since it was not mentioned yet, I will do it. This will not restart X as well. Presumably --restart is "stronger" than --reconfigure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.