Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed Debian and I am having issues getting my wireless working.

I installed Squeeze and also the nonfree firmware for iwlwifi.

I thought I did everything right but I am still not getting online. My wireless hardware won't even turn on.

So this is what I did:

Put the .deb files in a flash drive, booted the system and from there I typed dpkg -i <firmware>.deb

I restared my network first and then rebooted the PC after which I was still not getting a connection.

I typed aptitude show firmware iwlwifi and it showed all the files that were in /lib/firmware which where all correct.

modeprobe iwlwifi gives me a FATAL error saying the module isn't there and ifconfig/iwconfig only shows some eth0 and another interface that isn't wlan0

What could I be doing wrong? Was I supposed to download the "backport" firmware files instead?

Output of lspci -nn and dmesg|grep iwl:

http://paste.debian.net/179554

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.