Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have as issue with my ASUS X80L laptop ( system config: Celeron M 550, 2Gb RAM, Intel Mobile GM965/GL960 video ). I'm running Debian testing on it with X.Org v 1.12.1.902 and XFce 4.8.

Every 10-20 minutes my X-server is freeze for 20-60 seconds w/o any reason ( usually I'm using only IDE and opera browser for web-dev ). During freeze-time I can only move cursor and hear music on background.

Watching my /var/log/Xorg.0.log on a tty1 I see repeated entries (it repeats every time while X is not respond):

(II) AIGLX: Suspending AIGLX clients for VT switch
(II) Open ACPI successful (/var/run/acpid.socket)
(II) AIGLX: Resuming AIGLX clients after VT switch
(II) intel(0): EDID vendor "GSM", prod id 17503
(II) intel(0): Using hsync ranges from config file
(II) intel(0): Using vrefresh ranges from config file
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz eP)
(II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
(II) intel(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
(II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
(II) intel(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
(II) intel(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
(II) intel(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
(II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
(II) intel(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz e)
(II) intel(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
(II) intel(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
(--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found

Full log http://pastebin.com/raw.php?i=92JXreRW

Output of lspci -v http://pastebin.com/raw.php?i=QXWqsxZu

Xorg.conf

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us,uk(winkeys)"
    Option         "XkbOptions" "grp:alt_caps_toggle,grp_led:scroll"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LG"
    ModelName      "L1752HR"
    Option         "DPMS" "false"

    Modeline       "1280x800x0.0"   69.30  1280 1328 1360 1405  800 803 809 822 -hsync -vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "intel"

    VideoRam       524288
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24

    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I can't solve this issue by using google and forums. What's wrong?

upd. I'm performed test using laptop w/o external display, but I'm still get save freezes and errors. Here is dmesg output http://pastebin.com/raw.php?i=xf9B1jgh

Also, every time after that freezes my keyboard setting fall back to default, defined in xorg.conf. My xfce4 setting defines locales chagne by alt+caps, and left-alt as a compose-key. But it turn alt+shift to change locale, with no compose key.

upd 2 After changing my xorg.conf by adding some optioons regarding EDID

Option "UseEDID" "False"
Option "IgnoreEDID" "1"

There are no more error message in dmesg, but sometimes X-server freeze for the time (now for shorter time). And I've got some messages in my Xorg.0.log

[157600.245] (II) AIGLX: Suspending AIGLX clients for VT switch
[157605.263] (II) Open ACPI successful (/var/run/acpid.socket)
[157605.263] (II) AIGLX: Resuming AIGLX clients after VT switch
[157605.409] (II) intel(0): EDID vendor "LPL", prod id 297
[157605.409] (II) intel(0): Printing DDC gathered Modelines:
[157605.409] (II) intel(0): Modeline "1280x800"x0.0   69.30  1280 1328 1360 1405  800 803 809 822 -hsync -vsync (49.3 kHz eP)
[157605.810] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
share|improve this question
add comment

1 Answer

What messages are you getting by executing following command:

dmesg | tail

after that freeze?

Also make sure that your xorg.conf does exists, if not, create one (e.g. sudo Xorg -configure) or customize it by playing with the following options (in your Device section):

Option "UseEDID" "False"
Option "IgnoreEDID" "1"
Modes "1152X864" "1024X768" "800x600"

If this doesn't help, try to edit your: /etc/default/grub file and change (or add) the following line:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

If above solution doesn't help, then try to upgrade your distro to the latest version:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

restart your machine and check if it's solved.


See some of the following articles for some guidance:

http://www.thinkwiki.org/wiki/Intel_Graphics_Media_Accelerator_X3100

http://wiki.debian.org/XStrikeForce/HowToRandR12

http://crunchbanglinux.org/forums/topic/15374/solved-error-edid-checksum-is-invalid-remainder-is-130/

share|improve this answer
    
I've just got two 'freezes' in a couple minutes, here is dmesg output pastebin.com/raw.php?i=xf9B1jgh –  ntvf Aug 2 '12 at 12:42
    
I've updated the answer. –  kenorb Aug 2 '12 at 13:55
    
Disabling UseEDID and turning on IgnoreEDID seems work. –  ntvf Aug 2 '12 at 15:39
    
Unfortunately "IgnoreEDID" doesn't help me to get rid of a freezes. –  ntvf Aug 7 '12 at 11:17
    
Try to upgrade your distro by: sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade –  kenorb Aug 7 '12 at 13:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.